Z probe readings not consistent



  • Hey.

    I have problems with my BLTouch. If I want to create the mesh grid, this error happens randomly: "Error: Z probe readings not consistent".
    I even printed a stronger mount for the Probe.
    I have lowered the feed rate, even down to 70...
    I tried it with a max of ten times to probe each point.

    Unfortunately I could not set the debugging so that it gives me the individual probings.

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ;
    M558 P9 H5 F70 T4800 A4
    M557 X35:268 Y35:268 S20 ; Define mesh grid
    G31 X30 Y0 Z1.5 P50


  • administrators

    Are you probing with the bed heater turned on? If so, either probe with all heaters turned off, or add B1 to your M558 command. The B1 parameter only works in recent firmware versions.



  • I tried it with and without heater...



  • This will not help you get more consistent sensor results but it will allow you to print with some form of bed leveling. Have you tried to change the tolerance of the M558 command with the S parameter. The default according to this is 0.03mm. So raise it from that and see if you can still get reliable results.

    I am not sure I understand your message right but you can enable individual probes by reducing the number of Z-probe tries you do with the M558 A parameter. But that is a hacked solution as you will no longer get the benefit of smoothing out multiple erroneous readings.



  • You may need to take the pin out and clean it or adjust the set screw on the BLTouch. I had to do that with my original BLTouch Smart V1 since it was getting stuck sometimes and was very inconsistent. After cleaning the pin things improved drastically. For what it's worth, I recently damaged the pin irreparably and replaced it with a new BLTouch Smart V2 which uses a plastic pin and the results have been stellar. I hate to just say buy a new one, but for the 40$ if you can find a Smart V2 the results seem to be worth it.



  • This post is deleted!

 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.