Problems with tool selection



  • Hi all

    I use a cartesian style mendelmax 1.5

    When I start a print it works fine, the machine homes then it probes the bed next it waits for temps to be reached and it starts printing.
    Phenomenal really never had prints turn out this great.

    However, when a print fails like yesterday and i clean the bed to restart it (print didnt stuck on the bed) it does the same home, probe, but it does not wait for the printhead to reach temp.
    Instead the web interface gives me an AJAX error and the printer starts dancing around on the bed.

    When scouring these forums i found this could have to do with the tool selection, also i found that when you have T0 in your config.g you should start your Gcode for the print with T0 fololowed by M116

    I did this but im still having problems with restarting the prints.

    Also i updated to the 116 firmware along with the other 2 and did the command for updating it all at once.
    Now in the firmware tab on the webinterfac it still states the webcontrol as 1.12 instead of 1.13

    Could someone give me some advice on this?

    Config.g generated with the configurator and as is on my machine right now:
    ; Configuration file for Duet WiFi (firmware version 1.16)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Dec 11 2016 14:52:15 GMT+0100

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X200 Y200 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 Z0 S0 ; Define active low and unused microswitches
    M574 X1 Y1 S1 ; Define active high microswitches
    M558 P4 X0 Y0 Z1 I1 H5 F120 T6000 ; Set Z probe type to switch, the axes for which it is used and the probe + travel speeds
    G31 P600 X25 Y-10 Z1.47 ; Set Z probe trigger value, offset and trigger height

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z400 E419.51 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z300 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y200 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 R4700; Set thermistor + ADC parameters for heater 0
    M305 P1 R4700 ; Set thermistor + ADC parameters for heater 1
    M307 H1 A449.3 C181.7 D5.9 B0 ; Pid autotune M307 H0 A(gain) C(timeconstant) D(dead time) B0
    M307 H0 A49.5 C95.4 D8.9 B0

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 Pmendelmax ; Set machine name
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured

    T0

    Starting G-code of my slicer plus some of the first movement commands:

    ; generated by Slic3r 1.2.9 on 2016-12-15 at 19:34:24

    ; external perimeters extrusion width = 0.40mm
    ; perimeters extrusion width = 0.67mm
    ; infill extrusion width = 0.67mm
    ; solid infill extrusion width = 0.67mm
    ; top infill extrusion width = 0.67mm

    M190 S90 ; set bed temperature
    M104 S245 ; set temperature
    G28
    G32
    T0
    M116
    M109 S245 ; wait for temperature to be reached
    G21 ; set units to millimeters
    G90 ; use absolute coordinates
    M83 ; use relative distances for extrusion
    G1 E-3.00000 F900.00000
    G1 Z2.000 F9000.000
    G1 X58.802 Y54.039 F9000.000
    G1 Z0.200 F9000.000
    G1 E3.00000 F900.00000
    G1 X59.283 Y53.564 E0.01446 F2400.000

    Thank you !!


  • administrators

    Your starting gcode looks OK and ought to work. Are you sure that the prints that failed had the T0 and M116 commands in the starting gcode?

    I changed the behaviour in version 1.17RC1 to auto-select tool 0 if the slicer issues an M109 command without bothering to select a tool first.



  • yeah i read that in the other thread.

    i was really doubting this part
    "
    T0
    M116
    M109 S245 ; wait for temperature to be reached
    "

    Since the M109 S245 came after M116

    This Gcode i downloaded this morning from the printer after it failed yesterday evening, there's only one Gcode on it right now.
    Maybe its worth to mention i keep the bed on after the failed print so the bed is up to temp when restarting the print.

    Also a few times i got the error that extrusion was prevented because of cold hotend and after this i changed the starting G-code to what you see here.

    could you also elaborate why my firmware is telling me i run the 1.12 version of the web interface while i uploaded the 1.13 version ? should i just try to do the update again ?

    Also thanks again !


  • administrators

    The M116 should not be necessary in your case because the M109 comes after it. But I have seen cases where the slicer generate the only M104 and M109 commands before the user's custom start gcode. That's why I suggested the M116.

    If DWC is reporting that its version is 1.12 and you have already done a page refresh and tried clearing your browser cache, then try uploading 1.13 again. It takes several minutes to install on the Duet WiFi. The blue LED on the wifi module will stop flashing when it has finished installing.



  • I just updated

    WiFi Server Version: 1.03 (ch fork)
    Web Interface Version: 1.13

    Somehow they both didn't get through last time i tried.
    Also did an update to the RC1 version, testing it now.



  • Ok its awesome now!

    A big thank you for the help!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.