Bizarre fault on 5 thermistors; Convinced board went bad.



  • My machine has been running perfectly, though use has been sporadic in the past few months. I have both single extruder and four extruder toolheads that I can switch between, and everything has been running good.

    Today I tried running a print and every single one of the 4 extruder thermistors, plus the bed thermistor (the one out of five bed thermistors that I can monitor from DWC) comes up as 2000 degrees with "Error: Temperature reading fault on heater X: sensor open circuit".

    The NTC 100K thermistors are all confirmed connected. Checked each one with an ohmmeter right where the cables connect to the Duet headers and they're all good. I have multiple toolheads and tried swapping out as a sanity check. Same thing. I tried plugging a separate NTC 100K thermistor right into one of the inputs on the board. Same thing. The thermistors are connected correctly.

    If it were an error with just one temperature channel you might blame an actual heater fault, but I have 9 (NINE) temperature sensors on this machine, 5 of which I can monitor from DWC, and every one I can see is giving me a fault. All the same fault. There's no sign of an intermittent connection, and the machine ran fine the last time I used it. Nothing has changed since then. Haven't touched the config files, nor the firmware, nor turned it on.

    I checked config.g. Looks the same as it always did. I deleted all the files from the SD card and copied my backup files over. I updated the firmware from 1.20 to 1.21. Same, same, same.

    To reiterate, wiring has not changed; nothing has changed. I've tried multiple toolheads.

    I convinced myself that everything is in perfect order, as it has been. Perhaps the firmware was corrupted some how? Cosmic rays ruining my day? The axes move normally and nothing else seems amiss. Is there a separate chip that handles temperature sensing? Did that go bad?

    So I tried the "erase" button, thinking I would REALLY reload the firmware. Sam-ba won't connect, and neither will BOSSA. By the way, the version of BOSSA in the Debian apt repository does work in GUI mode. I tried multiple USB cables thinking I might have a stupid charge-only cable, but I don't have a way to be sure my cables are good (just realized not a single other device in my house actually uses the micro-USB B for data).

    Possibilities there are that I'm just having bad luck getting the firmware to flash due to bad cables or some other annoying thing, OR the microcontroller really did get corrupted, and so royally that I can't even flash it.

    I really think this is a hardware issue. Looking for guidance. I'm at the point that I'm willing to throw money at it and buy new boards (Duet+Duex5).

    ~Justine


  • administrators

    When all thermistors read open circuit, that usually means a VSSA fault. If the Duet PCB revision is 1.0 or 1.01 then the VSSA fuse has probably failed due to a short between VSSA and +12V or +24V or +5V. See https://duet3d.dozuki.com/Wiki/Connector_and_spare_part_numbers#Section_VSSA_fuse.

    If your Duet is revision 1.02 or 1.03 then the fuse is self resetting, but you will get the same temperature reading error for as long as the fault persists.

    If you are trying to use Bossa to upload firmware, make sure it is version 1.8. Older versions don't recognise the processor type.



  • Oh good, fixable stuff! Okay, thanks.



  • dc42,

    When I try connecting with Sam-ba, I get the error Board Description File not found: expected integer but got ""

    Any clues on what's going on? Bossa 1.8 on Debian is going to be another rabbit hole.


  • administrators

    Please check that you are using sam-ba version 2.16 and that the installation of sam-ba completed successfully.



  • FYI, the "Fallback procedure #3" says to use 1.17, but no matter, it looks like it's an issue with the tk8.5 library on Debian. Seems like everyone who's running it on Linux is using Ubuntu.

    But it's fine, I just tried BOSSA 1.8 on a Windows VM and that worked and my Duet has firmware again. Thank you as always!

    Now to order that replacement fuse...


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.