Possibly faulty x-axis endstop port/pcb



  • Today I finished up my x axis on a custom build and was getting ready to connect the endstops I ran into a fault. The duet would not detect the endstop trigger event in the UI. The hardware light did light up and changed state upon clicking the endstop. At first, I thought this was an endstop problem so I switched it out for a known working one, still nothing. Then I started testing some gcode to make sure the endstops were configured correctly and they were. All gcode combinations did nothing to remedy the problem. I even re-flashed the firmware to check that and it did nothing. I talked with profesionals in my area such as Paul Chase who is very well known in my 3d printing community, and even he could not find a solution. My final attempt to locate the problem was with reassigning the axes and using a different endstop port - it worked. That finally showed that there could be some hardware fault with the x-axis endstop port. The X-axis endstop port is very important to my project. Any thoughts on what the problem could be?


  • administrators

    What type of endstop is it? Optical endstops in particular sometimes need a resistor changed to provide a signal close enough to 0V to register properly when powered from 3.3V. Otherwise they can pull the endstop input low enough to light the LED at partial brightness, but not low enough to register on the microcontroller.



  • @dc42 it is a regular microswitch connected with always closed and triggered open.

    Edit: it works with another duet board I have and with the other endstop ports.


  • administrators

    If you are certain that your config.g settings are the same on the two boards - in particular, the M574 command(s) - then it does sound that the Duet is faulty and you should ask for it to be repaired or replaced under warranty. There is a resistor between the endstop input and the microcontroller, and that may be cracked or incompletely soldered.



  • @dc42 Thanks for your time! I have checked to make sure that the commands are the same and I will reach out to filastruder.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.