Probing Distance & Auto Home Problems



  • Issue #1
    I am using a BLTouch. I have an issue with probing distance on my Delta. If I set my max build height too small, then the probe never reaches the bed before the probing motion is halted. If I set it too large, then the BLTouch can't fully deploy, and I get errors. Finding the perfect setting is challenging as my bed is not adjustable, and not very level or flat. My trigger height is exactly -2. Is there a way to increase the distance of the probing action?

    Issue #2
    If I start an Auto Home command with the end effector on the edge of my printable volume, all 3 axis move upward for a time, but then after 2 axis hit the end stops, and the third still has a long way to go, I get a horrible grinding/skipping noise from the stepper motors. What can be done to fix this? Obviously, I can manually center the effector before auto homing, but that involves getting up and crossing the room 🙂


  • administrators

    1. Increase the dive height. It's the H parameter in the M558 command.

    2. It sounds to me that some of the endstop switches are either not working, misconfigured, or connected to the wrong endstop inputs. Use the Machine Properties page of DWC or the M119 command to test the endstop switches, and make sure that the endstop switch connected to the X endstop input is on the tower with its motor connected to the X driver output, and similarly for the other endstop switches.

    HTH David



  • @dc42 Hi David! The endstops are functioning. If I autohome with the end effector starting in the center of the bed there is no issue. Here, I made a video to show the behavior: https://youtu.be/BWJnaEDL7q0

    P.S. Yes. thank you for the dive height. That's what I was looking for.


  • administrators

    @punamenon, I still think you have some of your endstop connections swapped. You can test this with G1 S1 moves. For example, send G91 then G1 S1 X100 F100 to send the X carriage slowly towards the top, then check whether the movement stops when you trigger the endstop switch at the top of that tower. Repeat for Y and Z.

    If that all works properly, please post your homedelta.g file



  • @dc42 Yes, the slow crawl to the top of each axis was halted by triggering the optical end stops with a screwdriver.

    Here is my homedelta.g file as requested:

    ; homedelta.g
    ; called to home all towers on a delta printer
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Jul 07 2018 01:55:09 GMT-0700 (Pacific Daylight Time)
    G91 ; relative positioning
    G1 S1 X555 Y555 Z555 F3600 ; move all towers to the high end stopping at the endstops (first pass)
    G1 X-5 Y-5 Z-5 F3600 S2 ; go down a few mm
    G1 S1 X10 Y10 Z10 F360 ; move all towers up once more (second pass)
    G1 Z-5 F6000 ; move down a few mm so that the nozzle can be centred
    G90 ; absolute positioning
    G1 X0 Y0 F6000 ; move X+Y to the centre
    M280 P3 S160 I1 ; Reset BLTouch



  • @dc42
    Some more things I've figured out about the behavior:

    • This only happens when the vertical trolley starts the homing motion in a position well below it's 'natural' position (where the nozzle is located at X0,Y0,Z0).
    • This only happens to the z stepper motor at the back of the printer. The other two stepper motors don't exhibit this behavior when the effector is placed in a similar position opposite them.
    • The behavior only happens with the first G28 after powering up the machine, or after the stepper motors have been disabled with an M84 command. After the initial G28, if the steppers remain in their enabled state, all subsiquent G28 commands function as they should regardless of nozzle position.


  • @dc42 I have solved my own problem by setting the "Maximum carriage travel" to a higher number.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.