seemecnc max v3.2 with bltouch and bed leveling not working



  • I upgraded a seemecnc max v3 to 3.2 becaus I liked the duet so much on my Ultibot D300VS+. I replaced the Bowden setup with a titan aero and a bltouch, trick laser arms and aluminum barbells. I’m running 2.01 beta 1 and 1.21.2-b2 dwc.
    The bltouch repeats at .02mm and has been very stable. When I autocalibrate ( S6) I get around .03 however when I print, the x positive side of the first layer is squished to nothing to the point of the stepper skipping while the rest of the first layer is fine. The bltouch is offset at about 4pm. When I rotate the effector, the problem follows it.
    It seems like auto calibrate should fix the tilt to some extent but it seems to be doing nothing. As a test I added an H-5.0 to all the points in bed.g that had an x positive component to see if that would cause it to print in the air on the x positive side of the print. It did nothing at all and that side of the print was still totally squished to nothing while the rest was ok.
    Am I not understanding the auticalibrate function?
    I also tried G29 and that did not help.
    I’m perplexed. Any thoughts much appreciated.

    Bed.g
    ;G30 P0 X0 Y90 Z-99999 ;points for stock effector. bltouch offset requires new points
    ;G30 P1 X95.26 Y55 Z-99999
    ;G30 P2 X100 Y-75 Z-99999
    ;G30 P3 X0 Y-130 Z-99999
    ;G30 P4 X-95.26 Y-55 Z-99999
    ;G30 P5 X-90 Y45 Z-99999
    G30 P0 X0 Y85 Z-99999 ;H-.11
    G30 P1 X90 Y55 Z-99999 H-5.0 ;try forcing it to print in the air on x positive side
    G30 P2 X85 Y-75 Z-99999 H-5.0 ; same
    G30 P3 X0 Y-120 Z-99999 ;H.31
    G30 P4 X-80 Y-55 Z-99999 ;H.20
    G30 P5 X-75 Y65 Z-99999 ;H.21

    G30 P6 X0 Y55 Z-99999
    G30 P7 X47.63 Y-27.5 Z-99999 H-5.0 ;try forcing to print in air on x positive side
    G30 P8 X-47.63 Y-27.5 Z-99999
    G30 P9 X0 Y0 Z-99999 S6

    M106 P2 T50 S0.5 H1

    G0 z300

    Config.g

    M550 PRMAXV32 ; Printer name
    M555 P2 ; Repetier Output
    M552 S1 ; Enable Wifi
    ;M575 P1 B57600 S1 ; PanelDue Comm Setup
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates

    M569 P0 S0 ; Drive 0 goes forwards (X)
    M569 P1 S0 ; Drive 1 goes forwards (Y)
    M569 P2 S0 ; Drive 2 goes forwards (Z)
    M569 P3 S0 ; Drive 3 goes forwards (E0)
    M569 P4 S0 ; Drive 4 goes forwards (E1)

    M307 H3 A-1 C-1 D-1 ;turn off heater 3 for bltouch

    M574 X2 Y2 Z2 S1 ; set endstop configuration (all endstops at high end, active high)
    M558 P9 H10 F100 T3000 A7 S0.02 ; set probe type for bltouch

    ;M665 R142.586 L300.50 B135 H374.575 X-0.561 Y-0.285 Z0 ; delta radius, diagonal rod length, printable radius and homed height
    ; Y X Z are tower angle offsets for stock bowden effector
    M665 R146.525 L300.5 B135 H325.561 X-0.3 Y-0.615 Z0 ; delta radius, diagonal rod length, printable radius and homed height
    ; Y X Z are tower angle offsets for titan aero
    M666 X-0.74 Y0.35 Z0.38 ; endstop offsets in mm

    M350 X16 Y16 Z16 E16:16 I1 ; Set 16x microstepping w/ Interpolation
    M92 X100 Y100 Z100 ; Set axis steps/mm
    M92 E830:830 ; Set extruder steps/mm

    M906 X1000 Y1000 Z1000 E1000:1000 I50 ; Set motor currents (mA) and idle current %
    M201 X1500 Y1500 Z1500 E1500 ; Accelerations (mm/s^2)
    M203 X9000 Y9000 Z9000 E4800 ; Maximum speeds (mm/min)
    M566 X1400 Y1400 Z1400 E1400 ; Maximum instant speed changes mm/minute

    M106 P0 H-1 ; Part Cooling Fan
    M106 P1 S0.5 H-1 ; Case fan
    M106 P2 T50 S0.5 H1 ; Heat sink fan

    M307 H0 B0 ; Heated Bed (H2)
    M305 P0 T100000 B4388 R4700 H30 L0 ; Bed thermistor

    M305 P1 T100000 B4388 R4700 H30 L0 ; Hot end Thermistor
    M563 P0 D0 H1 ; Hot end (T0), drive (E0), heater (H1)
    G10 P0 S0 R0 ; Hot end operating and standby temperatures

    ;Dual Extrusion Code
    ;M563 P1 D1 H1 ; Hot end (T1), drive (E1), heater (H1)
    ;G10 P1 S0 R0 ; Hot end (1) operating and standby temperatures

    ;M558 P5 I0 R0.4 F2500 H5 A6 S0.05 B1 ; Stock effector Strain gauge probe settings
    ;G31 P100 X0 Y0 Z-0.25 ; Stock effector Probe trigger and offset values

    G31 P25 X30 Y-19 Z.83 ;set bltouch offset,trigger

    M557 R95 S30 ; Define radius for G29
    M83 ; relative E
    ;M579 x1.008 y1.0 z0.99 ; adjust dimensions
    M501 ; Load saved config values
    T0 ; Select Tool 0



  • So I think this is an effector tilt problem. I put on a 713maker duet smart effector adapter, no wires and a bubble level. The bubble moves from one side of the circle to the other as I move the effector around.
    So lerhaps a new question. Shoukd autocalibrate be able to compensate for effector tilt?


  • administrators

    Auto calibration cannot compensate either for effector tilt or for the other consequences of the geometrical errors that cause it. See https://duet3d.dozuki.com/Wiki/Calibrating_a_delta_printer#Section_Make_sure_your_build_is_accurate for common causes



  • I tweaked frame a bit. If the bubble on the level that comes with the smart effector stays within the small black circle is that acceptable. autocalibrate now comes out between .017 and .020.



  • I also noted looking at the page for the escher height sensor, the comment about compensating for effector tilt in bed.g which I assume means using the H parameter. Somewhere else was a comment saying the H parameter on g30 was really only useful when deviations were less than 1mm. Mine are less than 1mm so then putting H values on the g30’s in bed.g should correct for any remaining effector tilt?


  • administrators

    Using H parameters on the G30 commands can compensate for the effect of varying effector tilt on the apparent trigger height of a sensor that is offset from the nozzle. However, whatever is causing the effector tilt will also cause other effects that cannot be compensated. So it's best to find the cause of the varying tilt and fix it.



    • list itemThx David. I’ll go after the mechanics again. Related question, on m122 why does it list 5 values for probe points and says bed compensation: none even after auto calibration. The pull down menu on auto calibrate button on dwc has 2 items, disable bed compensation(which does an m561 and thus relates to auto calibration) and a disable mesh compensation. So that control appears to call auto calibration, bed compensation. So I dont understand why m122 would say bed compensation:none even after doing g32?

  • administrators

    @4lathe said in seemecnc max v3.2 with bltouch and bed leveling not working:

    Thx David. I’ll go after the mechanics again. Related question, on m122 why does it list 5 values for probe points and says bed compensation: none even after auto calibration.

    Because auto calibration is completely different from bed compensation. On a delta, you can use both auto calibration and mesh bed compensation if you want to.

    The pull down menu on auto calibrate button on dwc has 2 items, disable bed compensation(which does an m561 and thus relates to auto calibration)...

    No it doesn't!

    ... and a disable mesh compensation. So that control appears to call auto calibration, bed compensation. So I dont understand why m122 would say bed compensation:none even after doing g32?

    Those two buttons in theory should do exactly the same thing. Due to a firmware bug they currently do slightly different things, but that will be fixed in the next 2.01beta release.



  • I’m running 2.01beta1 and 1.21.2-b2 ans when I press Disable bed compensation the console shows M561 being sent. When I press Disable mesh grid compensation, it issues G29 S2.

    I went back to searching for problems like mine where even after g32 followed by g29 I have one side of my print that is overly flattened. I found a comment that you made to daroosh that had him put a piece of paper stock on the bed,do mesh comp and move the head back over that area to check wether mesh comp was in effect. I tried that and sure enough it worked. Then I rotated my effector 120degrees and the problem followed it so it is in the printed effector or the bltouch mount on the effector. I’ve taken it apart checked squareness,etc but no go. Can I fake it out by putting a .20mm piece of paper on the high part ( or maybe the low part) of the bed and run mesh comp, remove the paper and then print? Or is that completely stupid?



  • Also using. The bubble level that came with the smart effector, is the bubble staying within the black circle signify that the effector is level”enough” to be corrected in firmware?


  • administrators

    @4lathe said in seemecnc max v3.2 with bltouch and bed leveling not working:

    Also using. The bubble level that came with the smart effector, is the bubble staying within the black circle signify that the effector is level”enough” to be corrected in firmware?

    The firmware cannot correct for any geometrical error that causes the effector tilt to vary with XY position.

    If rotating the effector 120 degrees moved the problem round, then I suspect that either the joint fixings on the effector are not all at the same height, or they don't all have the same spacing.



  • The problem is
    As an aside the oaper trick doesthat the joint fixings are cnc barbells from seemecnc on a 713maker aluminum effector. I have 3 of them and the same isdue with each one so I’m pretty sure it has something to do with the printed titan aero adapter that attaches to the 713maker effector or the bltouch mount.
    As an aside the paper truck does mostly work. I used .1mm paper cut in an arc on the high side of the bed and that eliminated the over squishing on that side. Not sure why just running mesh comp without the paper doesn’t fix it.



  • Edit got nessed up but I think the intent is clear. Sorry.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.