Dual Z Steppers - ZA moves, ZB Twitches.



  • New CoreXY Build in process and was just testing steppers in relative mode. All my steppers are confirmed to work, however, any stepper I plug into ZB only twitches. Any insights? Thanks in advanced!



  • Usually this is a bad crimp connection or switched wires in the stepper cabling.
    Have you tried a different (known good) cable?
    Have you tested the cable, that it is wired correctly?



  • All the steppers work fine - I confirmed this by attaching to other ports. The only port that has issues is ZB. Any stepper connected to ZB only twitches when I actuate Z motion, ZA works fine.


  • administrators

    ZA and ZB are wires in series, so motors connected to them should get exactly the same current. Perhaps there is a short between two pins of the ZB connector? I suggest you check whether there is a solder bridge on the underside of the board. Also check for a short between the pins using a multimeter if you have one.



  • @dc42 - Makes sense. Thanks for your suggestion, I'll take a look and check for shorts when I can get back to this Friday. Thanks!



  • @dc42 How do I check for shorts with a multimeter? Sorry for the dumb question.


  • administrators

    With no stepper motors connected, measure the resistance between pins 1 and 2 of the ZB connector, and also between pins 3 and 4.



  • OK, ZB has solder bridging L1 and 1A. Assuming that is not supposed to be there?! !! DO I just clip it, or hit it with a soldering iron? 0_1531508446217_IMG_3747.jpg


  • administrators

    That explains the problem! I suggest you remove it with a soldering iron, if you have a suitable one.



  • Thanks for pointing me in the right direction! Still getting different behavior with Z (both) making plenty of noise, but only moves in spurts. X&Y seem normal. Are my settings messed up?

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X32 Y32 Z32 E32 I0 ; Configure microstepping without interpolation
    M92 X160 Y160 Z3200 E476.5 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z6000 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout


  • administrators

    As your Z steps/mm is very high (3200), you should reduce your Z acceleration in M201 (try 50) and Z max speed in M203 (try 300).



  • I think I miscalcualted the Z steps by missing a point in this guide: https://betrue3d.dk/duet-wifi-generating-firmware-using-configurator/
    I redid the calc to 800 steps/mm and they run fine now.

    Thanks so much for your prompt attention! Great forum!


Log in to reply