Printer randomly shuts down mid print

  • I have been having a slight issue where the printer would, at first only once in a blue moon, but lately quite often, simply shuts itself down mid print. The time and location when it shuts down, are completely random.

    Just yesterday, it happened twice in the same file (first one got to a few mm up [roughly 30 mins in], second one failed at the first layer [roughly 6 mins in]).

    Having had the logging enabled, produced the following relevant parts:

    2018-07-12 13:11:21 Started printing file HexSurfaceVase3.gcode
    2018-07-12 13:43:22 Power off commanded
    2018-07-12 13:43:22 Resume-after-power-fail state saved
    2018-07-12 13:43:22 Print auto-paused due to low voltage
    power up + 00:00:00 Event logging started
    power up + 00:00:00 Warning: Heater 1 appears to be over-powered. If left on at full power, its temperature is predicted to reach 487C.
    power up + 00:00:01 WiFi module started
    power up + 00:00:09 WiFi module is connected to access point <ssid>, IP address <ip>
    power up + 00:04:58 Started printing file 0:/gcodes/HexSurfaceVase3.gcode
    power up + 00:10:58 Power off commanded
    power up + 00:00:00 Event logging started
    power up + 00:00:00 Warning: Heater 1 appears to be over-powered. If left on at full power, its temperature is predicted to reach 487C.

    In my setup, the printer is using the ATX commands, to keep the relay triggered (allowing AC to the PSU, keeping the printer on). So the printer can shut itself down, should it ever need to. In this case, I was watching the printer both times when it happened - the temperature did not visibly shot up to a point where it would cause any issues (from the reported temperature), in fact it remained within 1C of the target.

    I have also confirmed that the heater output is not faulty (like a blown mosfet), since the temperature only increases when requested to do so, and cools like it should.

    I have previously had the shutdown command in the printer's sleep.g macro (so that I can set the printer to shut itself down after a print, using the Duet Web Control sleep option), but have removed it after the first premature shutdown.

    I have also had the Heater Fault Detection on, but that have also been disabled (commented out) in my config.g file.

    Any idea where I can start trouble shoot this?

  • administrators

    The key lines are these:

    2018-07-12 13:43:22 Power off commanded
    power up + 00:10:58 Power off commanded

    That means the function AtxPowerOff was called. It can get called for the following reasons:

    1. M81 command executed. This could either be a plain M81 command that has just been received or encountered in the file being printed, or it could be the result of a previous deferred power down command (M81 S1) if all the thermostatic fans have been turned off.
    2. Heater fault detected. But in that case, a heater fault message would be logged first.

    Do you have M81 S1 in your slicer end GCode? If so then I recommend that you also add M80 in your start GCode to cancel any pending deferred power down command, to handle the case when you start a new print after the old one has finished but before the printer has powered down.

  • Hi @dc42 I have no M80/M81 in my slicer, as usually the printer should remain on after a print is done - I slice multiples to schedule them one after another and usually don't know it is the last one unless until it already started to print (which is why I had it in the sleep.g file, but removed it when I started experiencing shutdowns).

    I don't have thermostatic heaters, and thus don't defer shutdown with it.

    The only 2 places where the M81 is active is inside my Shutdown macro (which asks the user if it should shut down), or inside my Emergency stop trigger (trigger2.g). This macro homes in X and Y (which is what happened on the first failure, but not on the second failure).

    I am going to try running it without the emergency stop enabled (maybe there is a loose contact which may only sometimes disconnect).

Log in to reply