Problems with mesh grid compensation



  • Hello,

    I am having difficulties with mesh grid compensation. It seems that the reference point is not registered in Z-0. Therefore the printhead is never in the right Z-height.
    When I run mesh grid compensation I get two recurring differentiating results. The two pictures are taken 3 minutes apart. I can not figure out the issue.
    I have tried to change the BLtouch probe and look for mechanical issues.
    Any suggestions will be greatly appreciated!
    I am using a custom built Cartesian style 3D-printer with Duet Ethernet with BLtouch probe.

    Thanks in advance!
    1_1531984142090_10.09.46.jpg 0_1531984142089_10.05.51.jpg


  • administrators

    The two recurring results is a known issue with some older firmware versions, triggered by Z-homing the printer with mesh bed compensation enabled.. Please try the 2.01beta2 release.



  • Thank you for your reply.
    I am running 1.20beta1 now. Should i expect any issues from the update?


  • administrators

    Yes, movement of axes before homing them will be disabled by default. Use M564 H0 in config,g to allow it. See the whatsnew file for other changes that may affect you.


Log in to reply