Static IP help, and basic access at this point [Solved]



  • I have been following the steps from https://forum.duet3d.com/topic/4532/static-ip-solved
    It can connect to a windows laptop hotspot, and a tablet as well. However windows says 0 devices are connected. Blue LED indicator on the board is solid blue on, meaning connected. Once the hotspot on windows is turned off, the LED blinks meaning connection lost/trying to find one, so it was connected even though windows says its not.
    The IP address before this was dynamic, and we had to turn the WIFI on an off via commands M552 S0 and M552 S1 in console to have it tell us the current IP.
    My setnetwork file is :
    M552 S0 ;stop wifi
    G4 P1000 ;pause
    M587 S"duetswifi" P"12345678" I192.168.0.14 J192.168.0.1 K255.255.255.0 ;add my network and IP address,gateway,netmask

    Using M552 S0, M552 S1 in console now says the IP is 192.168.0.14, but we can not access it, page can not be displayed. https://imgur.com/a/iB0Z9By

    It would give us a random IP before each time it was turned on/off and that IP did work, but now the new static IP is not.



  • Remember that the Wifi module save the details of the M587 command on itself, and use that. You can't overwrite an existing WiFi configuration for an SSID by simply sending a new M587 with identical ssid. You first have to remove the existing one (M588 S"<duetswifi>") before adding it again with the new parameters.

    The relevant Gcode details are at https://duet3d.dozuki.com/Wiki/Gcode#Section_M588_Forget_WiFi_host_network

    I have previously tried to connect to a personal hotspot on both Windows and iOS and in both times it was unreliable. I did not troubleshoot further.



  • Re flashed the firmware, back to what is was, IP is now 192.168.137.171 of the board, after a restart of everything. After sending the command in console M587 S"duetswifi" P"12345678" to connect to the laptop hotspot, it gives us that IP address (192.168.137.171). The board's IP was 192.168.43.136 before. That tells me that the laptop changed itself from 192.168.43.1 to 192.168.137.1 for the hotspot.

    Question: This means I can not add on a static IP to the command such as --M587 S"duetswifi" P"12345678" I192.168.43.14 -- because part 3 of the IP address is dynamic for the hotspot. So unless I can make the hotspot fully static this is a waist of time?



  • I believe that was the same issue I ran into for these personal hotspots: each time they use a different IP address range.

    And that, combined with my computer first trying my ethernet connection to see if the IP exists on it, meant that I simply could not connect to it, while I needed the Ethernet (Internet etc), making it very inconvenient.

    I then bought a Wifi Access Point from a reputable manufacturer, one with a built-in 4-port network switch, and after installation found that it was only broadcasting on 5GHz. So I bought a cheap AP from a different manufacturer, which I ensured would have the 2.4GHz. That is now how I run my setup and it is stable and simply works (though I now need to have both APs near).


  • administrators

    @lolitsjack said in Static IP help, and basic access at this point:

    Re flashed the firmware, back to what is was, IP is now 192.168.137.171 of the board, after a restart of everything. After sending the command in console M587 S"duetswifi" P"12345678" to connect to the laptop hotspot, it gives us that IP address (192.168.137.171). The board's IP was 192.168.43.136 before. That tells me that the laptop changed itself from 192.168.43.1 to 192.168.137.1 for the hotspot.

    Question: This means I can not add on a static IP to the command such as --M587 S"duetswifi" P"12345678" I192.168.43.14 -- because part 3 of the IP address is dynamic for the hotspot. So unless I can make the hotspot fully static this is a waist of time?

    Isn't there a way to tell Windows to use a fixed IP address for its hotspot?



  • It seems difficult to find. To add even more to the problem, we are trying to pair it to an android tablet. Trying to find an App that makes a hotspot that allows you to configure the IPs manually.



  • What we are trying to do is make it as easy as possible, such as auto connecting, to a tablet. But right now we have to open console though YAT, send M552 S1 to have it connect and display its IP address that it is connected to the tablet with, open the web browser in the tablet and connect to that given IP address, which currently changes every time.

    My idea was to manually assign the Duet board an IP with the command M587 S"duetwifi" P"" I192.168.1.14 J192.168.1.1 K255.255.255.0 or just M587 S"duetwifi" P"" I192.168.1.14 and then find a way to make the hotspot host always be 192.168.1.## for all IPs that connect to it. We could then make a bookmark or the homepage for the tablet 192.168.1.14 so every time you turned to board and tablet on it was all connected and ready to go.

    However this is proving very difficult. \o/


  • administrators

    Have you considered running the Duet as an access point? See M589.



  • Are you talking about setting the Duet board as the hotspot? Making it broadcast its own network?

    I am slightly confused on what access point parameters means for this because to me it sounds like turning the board into an access point.

    M588 S"* "
    ok<LF>
    M589 S"test1" P"12345678" I192.168.42.14
    ok<LF>
    M552 S0
    ok<LF>
    M552 S1
    ok<LF>WiFi reported error: no known networks found<LF>WiFi module is idle<LF> ((( I know this is displayed because of M588 S"*" )))
    M589 S1
    M589: Bad or missing parameter<LF>ok<LF>



  • Yes, @dc42 means that the Duet creates the Wifi Hotspot, and you simply connect to it. Obviously this Wifi will not have Internet on it, but the Duet will always use the same IP address.

    Another option, which may work is the printer name (M550) setting. If this is set, the Duet will be able to respond to http://<duetname>.local when you are connected*. This should allow the printer to use a dynamic IP, and you don't specifically need to know what it is as your computer/tablet should be able to find it.

    The M550 command looks like: "M550 P<duetname>" but the name an't contain spaces and a bunch of other illegal characters for a domain name (things like "+=&" etc), since that is somewhat what you are creating. Also in addition to HTTP, the printer can also be accessed via FTP (in software like FileZilla) at server: "<duetname>.local"; username is "<duetname>" and password is the password set with M551.

    • In my previous Windows installation (before a refresh), a setting was disabled that prevented the "local discovery" that is required for this, however a bit of Googling fixed it and on the refreshed Windows it immediately worked.

  • administrators

    Your M598 parameters look OK to me, but you must use M552 S2 to start the WiFi module in access point mode. After that your laptop and smartphone should be able to see it if you scan for available networks.



  • Hi,

    The simplest way might be to setup your DHCP server so it hands out a fixed address to the printer, based on the printers MAC address.

    Whenever I want a "static" address this is what I do IF the device can use DHCP.

    Check your DHCP servers documentation for "reservation" or "fixed IP" or something like that.

    Frederick



  • @dc42 Thanks for the Help! Got it working how we want it. M552 S2 working like a charm, didn't know about S2.


Log in to reply