homing problem with z on tevo delta



  • Hi there,0_1532627534786_z-axis.PNG

    I have a little problem on my Tevo Delta with homing.
    z does not seem to home, but after a few seconds the motor starts. Unfortunately it does not reach the top and stops about 10cm before reaching the top. (see attached)
    My x and y axis are working fine, but z still causes problems.
    I already tried to swap my z controller to e1 (P4), but still no success.

    I have checked all wires and pinnings several times. I also crimped some again. I tried different cables. All motors are working. Amperage is fine too.

    Now the strange point: If I swap the cable e.g.: from z and y, then the problem occures on my y axis and z is fine then.

    I am running out of ideas what the problem could be.
    (btw: I am running 1.21. I upgraded too, but without success.)

    Thanks for help in advance 🙂


  • administrators

    I suggest you start by testing the motors individually as described at https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareDeltaPrinter#Section_Testing_the_motors_individually.

    When you swapped the Z and Y motor cables, did you exchange just the connectors where they plug into the Duet; or are there connectors at the stepper motor end too and you swapped the stepper motor connectors as well?



  • @dc42 Hi,

    Thank you for the quick response! 🙂
    I tested both ways. But the motors are working fine. I already tested them seperately.


  • administrators

    @reckham said in homing problem with z on tevo delta:

    I tested both ways. But the motors are working fine. I already tested them seperately.

    Did you test them using G1 s2 commands, as described on that page? That tests the complete motor/cable/driver/firmware configuration combination.



  • I tested them seperately, yes.
    G91 and then seperately.
    Z does not react. But if i swap the connector from the z motor to the y motor (cables on board stay), then the y axis does not react.
    I also tested moving my z to P4 (second extruder spot on board). Same problem.
    Might this be a board problem? Or is the problem still anywhere else?


  • administrators

    Do you have 2 jumpers in the unused Z motor connector?



  • Fixed. Thank you very much! 🙂
    Have a nice day 🙂


Log in to reply