WiFi Setup problem



  • Hello everybody.
    I am writing regards duet wifi conection issue.
    I get timed out while trying to connect to network. Other boards connects without problem (other printer stands by side).
    I have tried to insert other SD card (from working board) with no luck.
    Do you have any solution for that?

    0_1533041126403_111.png


  • administrators

    When you say "other boards", so you mean other Duet WiFis?

    is this Duet running the same version of DuetWiFiServer as the others? Run M122 and look in the Network section of the report to find out.



  • Yes, there is 2 identical boards with same firmware etc...
    When running M122 I get === Diagnostics ===<LF>Used output buffers: 1 of 32 (13 max)<LF>=== Platform ===<LF>RepRapFirmware for Duet 2 WiFi/Ethernet version 1.21 running on Duet WiFi 1.02 or later + DueX2<LF>Board ID: 08DGM-956GU-DJMSN-6JTD8-3SN6K-KUNMF<LF>Static ram used: 16152<LF>Dynamic ram used: 100504<LF>Recycled dynamic ram: 2128<LF>Stack ram used: 3576 current, 6672 maximum<LF>Never used ram: 5616<LF>Last reset 00:41:27 ago, cause: power up<LF>Last software reset time unknown, reason: User, spinning module GCodes, available RAM 7840 bytes (slot 3)<LF>Software reset code 0x0003 HFSR 0x00000000, CFSR 0x00000000, ICSR 0x0441f000, BFAR 0xe000ed38, SP 0xffffffff<LF>Error status: 0<LF>Free file entries: 10<LF>SD card 0 detected, interface speed: 20.0MBytes/sec<LF>SD card longest block write time: 0.0ms<LF>MCU temperature: min 32.8, current 33.1, max 33.2<LF>Supply voltage: min 12.1, current 12.2, max 12.3, under voltage events: 0, over voltage events: 0<LF>Driver 0: standstill, SG min/max not available<LF>Driver 1: standstill, SG min/max not available<LF>Driver 2: stands<Warning: Maximal number of bytes per line exceeded! Check the end-of-line settings or increase the limit in the advanced terminal settings.>


  • administrators

    Change the line ending to <LF> in the YAT text settings to get the full diagnostic output, in particular the DuetWiFiServer version.



  • === Network ===<LF>
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)<LF>
    HTTP sessions: 0 of 8<LF>

    • WiFi -<LF>
      Network state is running<LF>
      WiFi module is idle<LF>
      Failed messages: pending 0, notready 0, noresp 0<LF>
      WiFi firmware version 1.21RC4(08b3)<LF>
      WiFi MAC address 5c:cf:7f:76:70:a5<LF>
      WiFi Vcc 3.32, reset reason Hardware watchdog<LF>
      WiFi flash size 4194304, free heap 21488<LF>
      Socket states: 0 0 0 0 0 0 0 0<LF>
      === Expansion ===<LF>
      DueX I2C errors 0<LF>
      ok<LF>


  • Ok. Looks like other board uses 1.20 version.
    How do I downgrade?



  • What I really love about Duet is that I can find most of the stuff online
    https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware
    Probably Fallback #1 should work


  • administrators

    I suggest you try installing the official DuetWiFiServer 1.21 release first, in case it performs better than 1.21RC4 that you are currently running.



  • Still get the same problem....

    0_1533120446025_c88d271f-fa88-4438-8f95-6c93d05cb34d-image.png


  • administrators

    We need to establish whether your newer Duet is faulty, or the newer firmware is incompatible with your router. So you can either try the latest firmware on your older Duet, or the older firmware on the new Duet.



  • Both duets were bought at the same time and I think they are both identical regards hardware.
    However later tomorrow I will try to make some tests and maybe clean flash of latest official software.





  • Ok, it was just accidental conection (1 time) and after restart not working again
    ...


  • administrators

    So are both boards running latest firmware now, but only one of them connecting?



  • Yes.
    Have tried all firmwares from 1.19 to now....


  • administrators

    If both boards are running the same firmware including the same version of DuetWiFiserver, but only one of them connects, please ask for the second board to be replaced or its WiFi module replaced. You can send M122 and look in the network section of the report to check which version of DuetWiFiServer is installed.



  • Just got from business trip and back to printers.

    Whatever firmware I would be using I cant connect to network that other printer is connected.

    BUT, I made a hotspot from phone and VUALIA. Works like a charm.
    How to solve this problem, or its unsolvable?


  • administrators

    Do both Duets succeed in connecting to your router, i.e. the blue LED flashes and then goes solid?

    Please confirm that you did not specify a fixed IP address in your M587 commands, or if you did then you used a different IP address for each Duet.



  • Connecting to phone hotspot:
    Board 1 - OK
    Board 2 - Ok

    Connecting to normal wifi router:
    Board 1 - OK
    Board 2 - NOT OK. Times out while connecting.

    I did not specify fixed IP. I setup up both boards same way by using ssid and pasword


  • administrators

    @alishkus said in WiFi Setup problem:

    Board 2 - NOT OK. Times out while connecting.

    1. If you connect YAT or another terminal emulator on a PC via USB (or use PanelDue if you have one), and send M552 S1 to try to connect board 2 to your router, what is the exact message that it returns when it gives up?

    2. Perhaps the wifi signal at board 2 is too weak. Are boards 1 and 2 equally close to the router? Is board 2 mounted in a position (e.g. inside a metal-framed printer) such that the wifi signal will be attenuated? Will board 2 connect if you position it very close to the router?


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.