Duet 2 Maestro + Quadfusion Dev Here: Halp?



  • Hey Folks,

    I'm one of the developers that is currently setting up the QuadFusion mixing head from M3D. I'm mostly known for my contributions to the Klipper and Marlin projects; anyways, I have the QuadFusion head, the Duet 2 Maestro + 2 expansion steppers. . For testing purposes, i'm converting a rather simple machine(the Ender 3) to use the head.

    I am running into a few issues though; even after reading the section regarding issues with Z homing in the 'common problems' section. It seems like the z-endstop does not react and begins catching/stalling. I'm not really sure what's happening with my stepping on the Z leadscrew either.. it is moving vastly more than it should, even though I have everything set correctly on the board and in the config.

    Anyone out there this evening willing to work with me on this? You get choice of first full color print. =P

    Thanks,

    David



  • Can you post your Config.g?



  • Sounds like the z steps are off and the endstop config isn't quite right but need to see the config.g and probably the homing files as well for good measure. What firmware version?



  • Prepping everything for you guys right now; I used the configurator to generate this... one moment and i'll post.



  • The configurator has.one major flaw, it gives you exactly what you ask for. 😉 Unfortunately that's not always what you need. Shouldn't require much tweaking to get you going.

    You'll need to know what the steps per mm should be for your axis. I'm not familiar with what the ender 3 ships with off hand.



  • Firmware Name: RepRapFirmware for Duet 2 Maestro
    Firmware Electronics: Duet Maestro 1.0
    Firmware Version: 2.01beta2(RTOS) (2018-07-14b5)
    Web Interface Version: 1.21.2-dc42

    0_1533091777863_config.g 3_1533091788874_homez.g 2_1533091788874_homey.g 1_1533091788873_homex.g 0_1533091788872_homeall.g

    Sorry to be such a total noob here -- I am just not understanding part of the duet structure, I think.



  • Just an FYI -- 4 of my drivers are being used to drive my extruder, if that looks odd =P



  • 2560 for the z axis steps per mm definitely looks weird.

    I'll take a look at the rest and get back to you shortly.



  • Also you don't have a z Endstop defined at all.



  • ; Endstops
    M574 X1 Y1 S0 ; Set active low endstops

    Add a z1 in there and comment out the m558 command below that.



  • I just located this in the original Ender3 firmware; the value was way off for me too... looks like it should be closer to 400. I'm trying that now.



  • Okay.. .things are getting better; but it's still like my Z-axis is inverted... plus, it doesn't respond normally to the endstop being activated. Here's the updated files: 4_1533094853578_homez.g 3_1533094853578_homey.g 2_1533094853578_homex.g 1_1533094853578_homeall.g 0_1533094853578_config.g

    SEems like there's a bug that prevents Z from going into the list of endstops, this was after using the configurator again.



  • To correct the direction its a simple fix, Im guessing your Z drive is P2 like the duet. In that case change the
    M569 P2 S1

    To
    M569 P2 S0

    What kind of endstop are you using?



  • I am utilizing the stock creality endstops for the cr-10, have them wired correctly but i think i've found the problem.. just gonna reverse diretiion of z.



  • when the endstop triggered, how did the machine react? continue as if it wasnt triggered or did something else happen. Also was this happening when you home all the the axis interdependently? or did you hit home all? The configurator tends to royally screw up the Homeall.g file



  • So, after making the change to Z's direction, everything seems to be going nicely. Now it's time to mount the CMYK head and see about some full color printing. 😃 I altered my original plate(not in a way hat would prevent it from functioning in teh stock config.. just two holes w/ some standoffs). Heeeere we go.



  • Thanks guys -- will report back with results. 😃



  • Awesome. Glad it's working out. Can't wait to see what the quad head can do. Very exciting tech.



  • Me too! In addition, we will be holding our first AMF meeting this Friday to discuss an open color standard. So many excited things on the horizon; I am really glad to see the duet community is so helpful and healthy; the same can't be said for most... we strive for this in Klipper as well. I will definetely keep everyone updated as to the results and progress we make as we continue to flesh out true color mixing.



  • And by the way Phaedrux; looks like that Z-endstop issue is a bug with teh configurator.. no matter how I defined my settings(Even going back to ensure it was set, after the probe section was completed) it would not include Z as an endstop... is there an easy way to mark this as a bug on the website, or just do it on github? Thanks again for your help.


Log in to reply