Help with dc42's IR probe



  • Hi - installed probe as suggested on David's web page, but it only reads 1000 or zero. LED comes on and triggers, changing the surface (buildtak to white card) does nothing to alter the readings. Turned all overhead lights off, back on. Wiring looks good. Any other suggestions what could be going wrong?


  • administrators

    Does the red LED on the sensor board flash 2 or 4 times when you power it up? If it flashes 2 times, then it is powering up in digital mode instead of analog mode. The usual reason for this is selecting the wrong Z probe mode, which is the P parameter in the M558 command in config.g. It should be P1.



  • That's it, thanks! Had some other issues with bed.g getting called when I hadn't realised it, but I've commented that file out and there's still something weird going on. It seems to ignore the M557 command in the config.g and when I run mesh grid compensation, it just goes ahead and starts testing lots of points instead of the fairly small number I defined. How I am meant to set all this up?

    M558 P1 ; Set Z probe type to switch and the dive height + speeds
    G31 P500 Z2.119 ; Set Z probe trigger value, offset and trigger height

    ; mesh grid
    M557 X15:150 Y15:150 S12 ; Define mesh grid


  • administrators

    @biscuitlad said in Help with dc42's IR probe:

    M557 X15:150 Y15:150 S12 ; Define mesh grid

    You are asking it to probe at 12mm intervals over distances of 135mm in X and Y. That's a 12x12 grid, so 144 points in all.



  • Groan, should have guessed! Oh well, it's just finished. I'll make that change in the gcode and hopefully it should be good to go.

    So having run it, will it now automatically compensate for the bed or do I need to do something further?



  • Actually I still can't get this to work properly. I've tried to recalibrate it several times, each times it's giving me different values using G31 S-1 after I set the G92 Z0 value.

    I add whatever value it comes up to the config.g, reboot and run the mesh grid comp, and try and print. It then crashes the print head into the bed. Every time!

    It's like it thinks the bed is a millimetre lower than it is. I tried using a bit of card, a bit of paper, and nothing. It doesn't make any difference. When I try and print, it tries to wreck my buildtak. 😞


  • administrators

    There is an issue with some older firmware versions if you re-home Z with mesh bed compensation applied. I recommend you upgrade to firmware 2.01 and then run G29 to generate the height map again.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.