Question about halted


  • Banned

    If for whatever reason printer goes into halted state how do I restore/ un halted state and continue print?
    I get this halted state with no know error. I understand it's a problem with 1.19.2 firmware. I have asked what firmware I should use, with no answer so far. That was 2 months ago. I have a gantry 3 axis plain style /pursa like printer. I do have all external drives and 3 extruders. My setup is well understood and works beautiful with firmware excluding this random halted state. I am unsure how to unhalt the state. File is still active. I selected the don't restart firmware option but heaters are switched off. How do I continue. I know there isn't an actual fault issue. It happens when I make a change like feed rate or temp up down during print. I make changes many times with no issue, but some times just clicking the slider for feed rate will cause it.


  • administrators

    Do you really mean it has gone into the Halted state, as shown on DWC or PanelDue? Or do you mean it has gone into the Pause state because of a heater fault?

    The only reason that the firmware goes into the Halted state is that it has processed the Emergency Stop command (M112). The only way to get it out of the Halted state is to reset the Duet.

    Some older firmware versions may incorrectly recognise a command sent by DWC that contains an embedded M112 string as an emergency stop. For example, if you ask to run a macro or print a file and the name of the macro or file has the string M112 embedded within it, that might cause the printer to stop. That was fixed in a more recent firmware release. But it shouldn't be possible for ordinary commands sent by DWC to be mis-recognised as Emergency Stop.

    If it has gone into the Pause state due to a heater fault, you can use the M562 command to reset the temperature fault, then press Resume.


  • Banned

    Nothing on haven or earth moves it out of that state. I reset it. It show no fault, but still was locked up. The coordinates didn't rest after reset. Psu where turned of and back again. this was a full reset cycle. I even went in config.G and hit save to force another restart. Same thing. Print file was gone, but position was still showing coordinate of position. Also I had to unplug it and repower board logic to get it back. I'm trying to upgrade firmware and getting error firmware not for this electronics. It's gen 2 Ethernet board. I downloaded th combine firmware.bin. I m997 S0 and same error. I usb transferred now error Ethernet firmware.bin not found. Lastly I removed sd and uploaded to card direct with restart. No good either. I renamed file Ethernet firmware.bin and error firmware not correct for these electronics. I tried 2 other firmware options 1.20. with same results. Boards not excepting these version. What now?
    I have never found a fault code for heaters and now record of any, but halted state happens about 1 in 5 prints, always as a result of web interface control during print. Even going from 80% to 90% feed rate on slider and Halted instantly.


  • administrators

    Where is it showing Halted: in Duet web Control, or in PanelDue? Either way, when you reset the Duet it may take a little while for DWC and PanelDue to get new status info from the Duet and update the display.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.