[SOLVED] Duet Wifi non-responsive after firmware update



  • My initial problem was that I updated the DWC to v1.13(and forgot to make sure that the main firmware was first), and then let it reset as the web based update control asked to do.
    After that point, I got the 404 page on the IP address that had been serving the Duet control page, and I believe the Display Due was also showing "Connecting" in the top right corner, but that may have come later.

    I was still able to connect to the Duet through Repetier Host, so I tried manually dropping the firmware in the sys folder and running the M commands given in the Backup Procedure #1, to no avail.

    After this, I moved to Procedure #2, and had no luck either.

    Finally resorting to the nuclear option, I went to #3, pressed the erase and reset buttons, and have had nothing but trouble since.

    Trying to connect to the Duet while in Ubuntu Linux using SAM-BA 2.16 would only hang the program on the chipset selection window, requiring killing the process to clear it, or pulling the USB cable.
    If started from a command prompt, it appeared to be hung while trying to open the chipset .tcl file, as it never went beyond that point.

    Rebooting into Windows 7 and installing the Windows version of SAM-BA, it appears to have installed the firmware, but after that, nothing happens.
    Once I close SAM-BA and then reset the board, I hear the disconnected device sound from Windows, and no following connecting device, nor is anything new visible in the device manager, or to Repetier Host. The Panel Due is also still showing "Connecting" on the top right corner of the screen.

    I have tried re-programming the Duet a few times now, using both the Stable and Edge versions of the firmware, with no difference in behavior.
    The disconnect and then reconnect tones do play when the board is erased and then reset, but nothing after the reset following programming.

    At this point, I am open to any suggestions.

    Note: This board is not currently installed in a machine at all. The power LEDs are both lit, as are the USB and Diag LEDs.

    The output from SAM-BA is as follows:
    loading history file … 0 events added
    SAM-BA console display active (Tcl8.5.9 / Tk8.5.9)
    (sam-ba_2.16) 1 %
    (sam-ba_2.16) 1 % send_file {Flash} "M:/Downloads/DuetWifi/stable/DuetWiFiFirmware.bin" 0x400000 0
    -I- Send File M:/Downloads/DuetWifi/stable/DuetWiFiFirmware.bin at address 0x400000
    first_sector 0 last_sector 4
    -I- Writing: 0x8D94 bytes at 0x0 (buffer addr : 0x20002128)
    -I- 0x8D94 bytes written by applet
    -I- Sector 0 locked
    -I- Sector 1 locked
    -I- Sector 2 locked
    -I- Sector 3 locked
    -I- Sector 4 locked
    (sam-ba_2.16) 1 % FLASH::ScriptGPNMV 2
    -I- GPNVM1 set
    (sam-ba_2.16) 1 %

    I do wonder about the (sam-ba_2.16) 1 % at the end of two lines, but was assuming that this must be an interface statement of some sort, and not a percentage?



  • Ok, I feel like an idiot…

    I started looking at the files, and thought that ~30Kb across the board was an interesting size for every file that I'd downloaded to have, whether it was the IAP4E.bin, main firmware.bin, or the web control .bin file.

    Looking at github again, and opening the files fully, shows that I'd managed to download the github page for each file, not the actual files.

    On that note, I just erased and flashed the board again, this time loading the actual DuetWiFiFirmware-1.17rc3.bin and it appears to have loaded. It also took up ~32 sectors of memory, rather than 4, and is currently searching for drivers for a Duet device after resetting.

    That said, I still have a 404 error page on the web control, but can now connect to the controller with Repetier Host again.



  • Re-downloading the Web Control firmware (also ~30kb initially. Hmm… I wonder why it didn't work?) and updating it with M997 S2 yielded a working web interface again.

    Many thanks to whoever took the time to write the Wiki here, and those who reply the various confused users!

    Now I just need to install this on the printer it's headed into, so I can print more parts for the printer that will house it's sibling that is in the mail from Filastruder...



  • Hello Im pretty new here but i just got a duet wifi and was getting it set up. When i did the update (i might have done it in the wrong order) but it wouldn't let me continue with any updates, so i referred to the forums where i i read to just erase and reset then retry. so i went along and did so and now i basically have a brick. i have pulled the sd card and copied the new firmware file and commented out the m552 s1 command and reinserted it. going to pronterface the board wont connect so i went on to step 3 and upon doing so re erased and reset board then prompted samba which opens, then i select the board type and connect, nothing happens. So as i am getting pretty frustrated at this point i just figured id as the pros as nothing i have found in the forums has been working. thank you



  • I am having the same issue as Steven. I just flashed the firmware (because I erased by accident). I hit reset and after the reset nothing is finding it. If I erase it sees it.. I feel like I am doing something wrong.


  • administrators

    After flashing the firmware, you may need to move the usb cable to a a different port on your pc or usb hub, or reboot the PC, or power the hub down and up again (including disconnecting it from the pc). I find that windows sometimes stops serving some ports on a usb hub.



  • There is an issue with github, when downloading the firmware.

    If you right click on the firmware file in the folder and select "save link as" you get an approx. 30kb file which is obviously not correct. I've done it foolishly 3 times, and flashed it and had to do the hard reset option.

    Instead left click the file, github will then display a grey box saying "view raw", and a button on the right "download". A left click there will get you the full 260kb file.

    Before the move to auto update from DWC (essentially OTA update) I think some sort of MD5 check or something like that would be a lifesaver and its quick enough to do, and common practice with things like smartphone Roms, where the consequences of flashing a corrupt file can be permanently bricking your device. I accept this is not a risk with a corrupt firmware on this device.

    I checked the wiki and the instructions there are clear.

    Might there also be an argument to host the firmware files on the duet3d.com site somewhere with slightly more conventional download behaviour, i.e. right click would work etc…


Log in to reply