Axis steps/mm issues - moving too far - fixed i think.



  • Background, I'm retrofitting an old Rostock Max V1 with 15 -tooth pulleys and 106.67 steps/mm - I began doing some tests to set height before running autocalibration. The problem is, my motors are moving too far no matter what I enter for axis steps per mm.

    My config.g has this: M92 X106.7 Y106.7 Z106.7

    With a ruler the height from my nozzle to my bed is about 385mm. When I hit Z-100 twice, I hit the bed. But the web interface reads approximately Z180.
    When I start from home position (385mm) and go down by 10 (Z-10) when I'm supposed to be at ~300, I'm at 285 or so.

    I've tried numerous attempts at changing the M92 values, including raising the steps/mm by 50 and lowering them by 50 - but this seems to have no effect at all. That is,
    M92 X156.7 Y156.7 Z156.7 and M92 X56.7 Y56.7 Z56.7 - reach the same height of around 285 after hitting Z-10 8 times from a home height of 385.

    I did try rebooting it after changes, in addition to just hitting save changes and disconnecting/reconnecting. No joy.

    I don't know what to try next. Any ideas?



  • Addendum, Okay, something has changed for the better - but I'm at a loss why this worked.
    I'd also had a heater fault, and entered M562 P1 to reset it.

    Doing that seems to have reset the motors though it shouldn't have any effect at all. Now, at least I can make changes with the M92 and they seem to have the right effect.

    Weird.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.