Can't stop my heated bed and extruder



  • Hello all, I'm new to the Duet3D community. I was setting up my new Duet WiFi board today and everything was going great, my CoreXY printer was homing properly and my dual z axis were working together. Then on my last few reboots I saw that my heated components were coming on. I tried setting the active temperatures to zero, I tried rebooting a few times, even tried setting the temperatures with manual g-code. I will note that my heated bed is driven through a mosfet board.

    What can I do to stop it? I tried googling but I didn't see anything or anyone having my issues.

    Thanks,
    Kent

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Aug 18 2018 11:19:22 GMT-0500 (Central Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 PX5S ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Where I put stuff in
    M584 X0 Y1 Z2:3 U3 E4 ; Driver 0 For X, 1 for Y, Z=2:3 U=3, Extruder 4

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M350 X16 Y16 Z16:16 U16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z1600:1600 U1600 E420 ; Set steps per mm
    M566 X900 Y900 Z12:12 U12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180:180 U180 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250:250 U:250 E250 ; Set accelerations (mm/s^2)
    M906 X2000 Y2000 Z2000:2000 U2000 E800 I50 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0:0 U0 S1 ; Set axis minima
    M208 X330 Y330 Z400:400 U400 S0 ; Set axis maxima

    ; Endstops
    M574 X1 S0 ; Set active low endstops
    M574 Y1 Z1 U1 S1 ; Set active high endstops

    ; Filament run out
    M591 D1 P1 C4 S1

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:315 Y15:315 S20 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured



  • Including a screen shot of the web interface
    0_1534616688135_overheating.PNG



  • @thebigkent Regarding the bed driven through MOSFET board: they can fail shorted so it the bed will be on all the time. Do you have a spare MOSFET board to check against? Also why don't you use the Duet's terminals? They are rated for 18A. Does your bed exceed this?

    As for why the hotend is doing the same thing, I have to pass the question on. But it might of course be the same thing with Duet's on-board MOSFET for the hotend heater terminals.



  • @wilriker said in Can't stop my heated bed and extruder:

    @thebigkent Regarding the bed driven through MOSFET board: they can fail shorted so it the bed will be on all the time. Do you have a spare MOSFET board to check against? Also why don't you use the Duet's terminals? They are rated for 18A. Does your bed exceed this?

    As for why the hotend is doing the same thing, I have to pass the question on. But it might of course be the same thing with Duet's on-board MOSFET for the hotend heater terminals.

    The bed current isn't excessive but it's a 24V bed while the rest of my printer is running off of 12V. I'll try removing the mosfet board and seeing if that helps.

    Edit: Nope, the bed does heat much slower but I'm still uncontrollably heating.



  • @thebigkent said in Can't stop my heated bed and extruder:

    The bed current isn't excessive but it's a 24V bed while the rest of my printer is running off of 12V. I'll try removing the mosfet board and seeing if that helps.

    OK, in that case it would not make any sense to connect it directly to the Duet, I see. Still the MOSFET could have failed shorted. In this case also the MOSFET used on the Duet to control the bed that you again use to control your external MOSFET board could have shorted and therefore commanding your external MOSFET board to be on all the time.
    You could probably check this using a multimeter across Duet's bed terminals.

    1. If they show voltage although not explicitly heating then you most probably have a short on the board.
    2. If they don't and your bed still heats (did you touch the bed to check if it is actually hot and not your sensors are going haywire?) it probably is your external MOSFET board.


  • @wilriker said in Can't stop my heated bed and extruder:

    @thebigkent said in Can't stop my heated bed and extruder:

    The bed current isn't excessive but it's a 24V bed while the rest of my printer is running off of 12V. I'll try removing the mosfet board and seeing if that helps.

    OK, in that case it would not make any sense to connect it directly to the Duet, I see. Still the MOSFET could have failed shorted. In this case also the MOSFET used on the Duet to control the bed that you again use to control your external MOSFET board could have shorted and therefore commanding your external MOSFET board to be on all the time.
    You could probably check this using a multimeter across Duet's bed terminals.

    1. If they show voltage although not explicitly heating then you most probably have a short on the board.
    2. If they don't and your bed still heats (did you touch the bed to check if it is actually hot and not your sensors are going haywire?) it probably is your external MOSFET board.

    No, my first clue was the LED lighting up on my heated bed indicating that it was heating. I did double check and things were getting hot. I've managed to get it working but it's not an ideal scenario, I switched the jumper from internal 5v+ to external and am powering the board via the USB plug. I'm well on my way to my first duet powered print.


  • administrators

    If all the heaters turn on when you use the internal 5V regulator but not when you use external 5V power, then your Duet is faulty. Please do not use it (even with external 5V power), instead ask for it to be replaced under warranty.



  • @dc42 Okay, will do.


Log in to reply