esteps/mm values not being taken into account?



  • I'm running on Duet Wifi

    Firmware Version: 2.01(RTOS) (2018-07-26b2)
    WiFi Server Version: 1.21
    Web Interface Version: 1.21.2-dc42

    Am trying to adjust the esteps/mm and editing the M92 E304: XXX line in config.g doesn't seem to make the blindest bit of difference to the amount extruded when run the 100mm test. (Tried values XXX = 304 up to 390 and always 95mm is extruded??)

    Has anything changed that means this line isn't taken into account?



  • Actually, don't remember/understand what the colon ":" is for?

    what does this syntax mean with two E numbers?

    when setting steps/mm for X and Y axes we just put one number?


  • Moderator

    The colon seperates values for multiple extruders. If you only have one extruder you only need one number.



  • @r123 That's because printers only have a single X and Y axis but often have multiple extruders (I have 5 on my mixing hot end). So the colon is used to set the steps per mm for each of the multiple extruders. If you only have a single extruder, you don't need the colon so taking it out might cute your problem.



  • Thanks a lot guys, that did it. Just put in one number and now it's perfectly calibrated.

    Goodness knows how long I've had two numbers in the config file have copy pasted someone elses to get started. Miracle made it so far!

    Thanks again



  • For sake of completeness: the default values for steps/mm

    • X/Y: 87.489
    • Z: 4000
    • E: 420

    So I guess you have been running on 420 all the time.


Log in to reply