Resuming Print fan after pause.



  • I am trying to get the print cooling fan resume after pause.

    === Here is my current pause.g :
    M83 ; relative extruder moves
    G1 E-5 F3600 ; retract 5mm of filament
    G91 ; relative positioning
    G1 Z5 F360 ; lift Z by 5mm
    G90 ; Absolute positioning
    G1 X0 Y0 F6000
    M106 S0 ;turn off Part Cooling Fan
    T2 ;Used to set extruder to 0.

    === current resume.g :
    T0 ; Active tool
    M116 P0 ; Wait for active temps to be reached
    M83 ; relative extruder moves
    G1 E7 F3600 ; prime 7mm of filament
    M106 P0 R1 ;Resume Cooling Fan Speed

    Have tried may ways but the print fan will not resume.

    Duet Firmware 1.21


  • administrators

    Try M106 R1 without the P0.



  • switched to :
    M106 R1 ;Resume Cooling Fan Speed

    Did not change, the print cooling fan stays off.


  • administrators

    I have added this to my list of things to test again.



  • Updated attempt
    Pause.g:

    M83 ; relative extruder moves
    G1 E-3 F3600 ; retract 3mm of filament
    G91 ; relative positioning
    G1 Z5 F360 ; lift Z by 5mm
    G90 ; Absolute positioning
    G1 X545 Y20 F6000 ; park over prime tank
    G1 X545 Y0 F6000 ; finish park over prime tank

    M106 P0 S0 ;Part Cooling fan Off
    M106 P3 S0 ;XY Motor Cooing fans off
    M106 P4 S0 ;Z Cooling fans off

    T2 ;switch extruder to 0 shut off hotend.

    M906 X100 Y100 Z100💯100:100 ; set idle motor Currents, they don't seem to be going idle during pause.
    M906 E0:0:0 ; Set motor currents (mA)


    Now the Resume :

    T0 ; Active tool, turns back on hotend

    ;==== reset all motor currents (Because not going idle during pause?.)
    M906 X1400 Y1400 Z1300:1300:1300:1300 ; set motor Currents
    M906 E900:900:900 ; Set motor currents (mA)

    M116 P0 ; Wait for active temps to be reached

    M106 P0 S90 ;Part Cooling fan 35% (because resume not working)
    M106 P3 S255 ;XY Motor Cooling fan full
    M106 P4 S255 ;Z Motor Cooling fan Full

    G90 ; Absolute positioning
    ;already over prime tank on pause.g

    M83 ; relative extruder moves
    G1 E7 F100 ; prime 7mm of filament

    G1 E-3 F3600 ; Retract 3

    G1 X535 Y0 F300 ; Wipe Nozzle

    G1 R1 X0 Y0 F6000 ; go back to the last print move
    G1 E3 F3600 ; UnRetract 3/prime


    The fan settings in the resume.g are the settings I use during the print.
    When I turn fans on in the resume.g the fans will come on, while completing the resume code.
    But ALL fans go back off when actual resume take place.


  • administrators

    It is only the print cooling fan whose settings are saved during pause/resume. I just tested that it works, by putting M106 S0 in the pause.g file. When I pause and then resume a print, adding that command causes the fan to turn off during the pause, then its speed is automatically restored when I resume. You don't need to put any M106 command in resume.g to achieve this behaviour.

    Were you hoping to achieve something different?



  • I would like to setup the printer so I can hit pause if I needed to leave the printer for an extended amount of time. ie work.
    Then resume with I get back, fully automated. I can do it now but have to restart some things manually.

    I did not want to shut off the printer completely because of possible registration problems.



  • @ehay said in Resuming Print fan after pause.:

    I would like to setup the printer so I can hit pause if I needed to leave the printer for an extended amount of time. ie work.
    Then resume with I get back, fully automated. I can do it now but have to restart some things manually.

    I did not want to shut off the printer completely because of possible registration problems.

    Can I presume you will be doing this only with prints that use a cold bed? I thought about this, but 90% of my prints are heated PEI, and the part would be totally detached after it's allowed to cool off.

    Just wondering...



  • @3dmntbighker
    PLA on cold bed. I use blue tape on aluminum. Sticks very well.

    Like your tag line. I could duplicate it exactly except I have 4 rails.


  • administrators

    So are you saying that you want to turn all the fans off when you pause, not just the print cooling fan (which is turned on automatically when you resume the print)? If so then the simplest option is to configure the other fans for thermostatic control, then they will only be on when needed.

    You could also turn the printer off completely after pausing it (wait for the hot end to cool down before you turn the hot end fan off) and then use the resurrection facility, if you configure it first. In the last several firmware versions, the resurrect.g file is created automatically whenever you pause the print. See https://duet3d.dozuki.com/Wiki/Setting_up_to_resume_a_print_after_a_power_failure.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.