New Duet Maestro firmware


  • administrators

    Some Duet Maestro users have experienced some issues related to the stepper drivers when using recent Duet Maestro builds of ReprapFirmware:

    • Spurious "short to ground" error reports
    • On the Promega printer, the bed being driven down at high speed if the Z motors stall

    I believe both issues are caused by configuring the TMC2224 stepper driver chips in stealthChop2 without also configuring an upper motor speed limit at which the driver changes over to spreadCycle mode. Older versions of the firmware use spreadCycle mode all the time, which does not suffer from the same issues; but under pressure from users I changed it to use stealthChop2 by default.

    To address this, I've put a new firmware binary at https://www.dropbox.com/s/m0r3ldy424mxf4v/DuetMaestroFirmware.bin?dl=0. This version programs the chips to switch to spreadCycle mode at higher speeds. So it may solve these problems. If you have experienced either of these issues, feel free to try it Caution: this is not an official beta release and has received only limited testing, so use it with care! You may wish to temporarily reduce the stepper motor currents, to reduce the possibility for damage.

    I have set the default crossover speed from stealthChop to spreadCycle to 2.5revs/sec for 1.8deg motors (1.25 revs/sec for 0.9deg motors). You can see what this is in mm/sec for your axis by sending M569 P# where # is the driver number.

    The TMC2224 datasheet says there may be a jerk at the crossover if the speed is set too high. If either you observe such a jerk, or the new firmware doesn't solve the problem, then I suggest you reduce the crossover speed by increasing the 'tpwmthrs' parameter using the V parameter of M569. For example, M569 P0 V186 will double 'tpwmthrs' from the default value of 93, which will halve the crossover speed.

    I am anxious to resolve this problem before we start selling the Duet Maestro at Duet3D and through our distributors, so I will be grateful for your feedback in this thread.


  • administrators

    Following some more testing, I've found that setting the crossover speed as high as I did does cause nasty jerks on my printer when accelerating decelerating through those speeds. So if you test this firmware, please can you add these lines to config.g to reduce the crossover speed:

    M569 P0 V2000
    M569 P1 V2000
    M569 P2 V2000
    M569 P3 V2000
    M569 P4 V2000

    This reduces the crossover speed to about 4.5mm/sec on the X and Y axes of typical Cartesian printers, at which the crossover is much gentler. The downside is that it may increase the noise during printing for some of you.



  • @dc42 The replacement LCD that was being rushed to me is here now; and I've got a fully built out set of Menu entries. I will be testing in the next few minutes.

    Thanks!

    David@M3D


  • administrators

    Thanks! I updated the firmware binary on Dropbox an hour ago to use V2000 as the default instead of V93.



  • @dc42 said in New Duet Maestro firmware:

    I am anxious to resolve this problem before we start selling the Duet Maestro at Duet3D and through our distributors, so I will be grateful for your feedback in this thread.

    Is there already a date for the availability of the Maestro sold by yourself?


Log in to reply