Poor Print Quality - struggling to debug firmware



  • im hoping for some help with my firmware and some reccomended settings for an AM8. im running 0.9 degree motors on X &Y 4.8mH 1.6A, 2 x 0.6A 1.8 degree motors on z and 1.8 degree 1.2A for the E.

    i was hoping someone could reccomend some ideal starter settings for the firmware.

    This is my current set up

    ; Configuration file for Duet Ethernet (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Sep 03 2018 19:40:27 GMT+0100 (GMT Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PMy printer ; Set machine name
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X200 Y200 Z400 E807 ; Set steps per mm
    M566 X1200 Y1200 Z12 E600 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E3000 ; Set maximum speeds (mm/min)
    M201 X1000 Y800 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X1300 Y1300 Z800 E1200 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X230 Y210 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y2 S1 ; Set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:215 Y15:195 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S1 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0.3 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not configured

    The system is running on 12V, would you reccomend going to 24V ?

    Thanks in advance!



  • Your settings look alright to me. Perhaps someone with an AM8 already tuned can verify, but you don't have anything really out of whack that I can see.

    The only value I would consider changing would be to reduce the X and Y jerk value in M566 by half. So M566 X600 Y600.

    Perhaps you can post some photos of the poor print quality you are seeing os we can better diagnose what's going on. Your slicer settings are going to have the biggest impact on quality, provided your mechanics are solid.

    A few more questions that could help:

    • What firmware versions are you running?
    • What type of extruder are you using?
    • Have you calibrated your E steps and extrusion multiplier?
    • Have you run a PID tuning on your hotend and bed?

    These articles may help you understand if 24v will be helpful to you or not:
    https://duet3d.dozuki.com/Wiki/Choosing_and_connecting_stepper_motors
    https://duet3d.dozuki.com/Wiki/Choosing_the_power_supply

    24v would potentially allow you to sustain higher speeds in travel moves, but I doubt the small size of your bed would warrant that. It would also require switching out your hotend heaters, fans, and heated bed for 24v compliant versions.



  • In addition to what was already said above me, you said you are using .9 degree steppers on x and y and 1.8 degree on z... but in your config.g, the steps per mm for the x and y are lower than the z. I am not familiar with your printer and it's mechanics, but I would assume that the x and y steps per mm should be higher than the z... It might be worth looking into.



  • @toddwagner Steps per mm depend heavily on the thread pitch of the lead screw and the tooth count of the pulleys. It's not uncommon for the Z axis to have much higher steps than the other axis. For example, a standard 8mm pitch lead screw with 1.8 motor would use 400 steps. We'd need to know the tooth count of the pulleys on X and Y and the tooth pitch of the belt to know if 200 is correct, but it's definitely out of the question, but it would be in line with the very common GT2 belts, and 16 tooth pulleys.

    If you know the specifics of your hardware you can find the correct steps permm with this:
    https://www.prusaprinters.org/calculator/


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.