Duet Web Control Doesn't connect



  • Hi folks, I hope this isn't a stupid first post - but a forum and Google search came up with nada so I'll take my chances.

    So I built my first delta and bought a couple weeks ago a Duet WiFi. The printer build is done except for the print head bits that are on order. In the mean time I decided to connect the duet and configure it for my network. Getting a connection with Pronterface went fine. Connecting via wifi and launching Duet Web Control went fine, but it didn't connect to the printer.

    So the directions say it should connect automatically, but hit the blue connect button on Duet Web Control if it doesn't, so I hit the connect button. Well, the button goes orange and says "Connecting…." and there it sits, no error message, no nothing.

    Am I doing something wrong?


  • administrators

    Have you enabled WiFi by sending M552 S1 in Pronterface or by putting it in config.g? Are you entering the correct IP address in your browser's address bar?



  • I am not having a problem connecting to the Web Control server by WiFi, the Web Server GUI isn't connecting to the printer through its internal "virtual" console interface.

    See the top left corner of this screen grab


  • administrators

    Which browser are you using? Chrome and Firefox work best. Have you tried opening the browser's debugging console to see if there are any exception messages?



  • Installing Firefox fixed it. Looks like it's broken in IE11.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.