Strange stepper motor behavior during a print.



  • Hello community.

    I recently experienced a unusual problem during a dry test print.
    (Just checking if the motor are working fine.)

    When i move the motor manually with the head movement X,Y,Z,
    everything works fine without a problem. But when i try the 'Testprint2' code,
    The motors will behave very strangely.

    The motors are are going to the the end-stops and the bed position.
    And after that the problem occurs. When the machine wants to print, the motors are barely moving and make a grinding noise. The motors won't budge then until the test print is over.

    Here's a video to explain it more easily:
    https://streamable.com/kr4d7

    (Note: the communication error was pure coincidence)

    • I use a 24V inverter
    • And a 0.9 angle stepper motors

    A funny thing is that the grinding noise is even louder when i use an other software like repetier host. (It sounds like a diesel engine in my room)

    I tried to change the steps to 16, 32, 64 and so on but that doesn't work either.

    What can i do to Stop the grinding and print normally with the motors?

    Thanks.


  • administrators

    Where did you get the "testprint2" code from, and what commands does it contain? Perhaps it is setting the maximum speeds (M203) or accelerations (M201) to values higher than your printer mechanics can manage.



  • Hello dc42.

    The testprint2 code was just from the firmware itself (User-Defined Macros.)

    The speed and acceleration has been set to the default value.

    • M201: Accelerations: X: 1000.0, Y: 1000.0, Z: 1000.0, E: 1000.0:1000.0:1000.0:1000.0:1000.0:1000.0:1000.0:1000.0:1000.0

    • M203: Maximum feedrates: X: 18000.0, Y: 18000.0, Z: 18000.0, E: 1200.0:1200.0:1200.0:1200.0:1200.0:1200.0:1200.0:1200.0:1200.0

    Here is the driver part of the config.g

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X200 Y200 Z200 E200 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1000 ; Set accelerations (mm/s^2)
    M906 X1700 Y1700 Z1700 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout



  • Can you post the gcode file?

    Have you tried any other gcode you've sliced yourself?

    It would seem like you have some binding going on still. At least binding when trying to print that gcode file. Perhaps it's trying to print at a ridiculous speed.



  • Hi Phaedrux

    I tried to print an other model with 'Repetier host' but that ended even worse the grinding sound was like 3 times louder and the glass fuse from the 24V inverter became extremely hot.

    Here is the Gcode from the 'Testprint2' program

    ; Test Routine for Duet WiFi and Ethernet April 2017
    M570 H1 P120 T120 ; Extend the heater H1 fault timeout to 120 seconds for testing
    M570 H2 P120 T120 ; Same for H2
    ; Test motors

    ; home all axes - trigger endstops manually - The following lines are from homedelta.g
    ;----homing lines----
    G91 ; use relative positioning
    G1 S1 X320 Y320 Z320 F2500 ; move all carriages up 320mm, stopping at the endstops
    G1 S2 X-3 Y-3 Z-3 ; move all carriages down 3mm
    G1 S1 X6 Y6 Z6 F250 ; move carriages slowly up 6mm, stopping at the endstops
    G1 Z-5 F2000 ; down a few mm so that we can centre the head
    G90 ; back to absolute positioning
    G1 X0 Y0 F2000 ; centre the head and set a reasonable feed rate
    ;----end homing lines----
    G1 Z100 F10000; Move Z down 100
    G4 P1000
    ; Test PWM fans
    M106 P0 S255
    G4 P4000
    M106 P0 S0
    M106 P1 S255
    G4 P4000
    M106 P1 S0
    M106 P2 S255
    G4 P4000
    M106 P2 S0
    ; Start heating bed
    M140 S50
    ;Override cold extrusion
    M302 P1
    T0 ; Select first extruder
    ; start heating hotend
    M104 S50
    G4 P4000
    ; extrude 50
    G1 E50 F1200
    G4 P1000
    ; retract 50
    G1 E-50 F1200
    G4 P1000
    ; turn off hotend
    M104 S0
    T1; Select second extruder
    M104 S50
    G4 P4000
    G1 E50 F1200
    G4 P1000
    G1 E-50 F1200
    G4 P1000
    M104 S0
    M140 S0
    M84; disable motors
    M117 END OF PRINT


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.