Can't upload G-code



  • I've just updated an old AnyCubic delta machine with a spare Duet board, and all was going fine for a few days, but this afternoon I can't upload any new files.

    Initially everything looks fine ...

    0_1536613392904_2018-09-10_16-44-19.png

    But then it comes up with an error.

    0_1536613431435_2018-09-10_16-44-32.png

    And the file is not uploaded. I've tried two different computers, with Firefox and Chrome. Same error every time. I've also tried different files. There was at 10MiB file on there I removed to check the card had space, but it didn't make any difference.

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 2.01(RTOS) (2018-07-26b2)
    WiFi Server Version: 1.21
    Web Interface Version: 1.22.3
    Web Interface by Christian Hammacher
    Licensed under the terms of the GPL v3

    Thank you for any help.



  • Can you copy and paste the results of an M122 diagnostics report?


  • administrators

    That indicates either an SD card write error, or that the size of the file size written wasn't correct.

    Perhaps you should try a different SD card?



  • M122 output

    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.01(RTOS) running on Duet WiFi 1.02 or later
    Board ID: 08DGM-9568A-F23SD-6J1F2-3SD6R-KVNMD
    Used output buffers: 3 of 20 (11 max)
    === RTOS ===
    Static ram: 28476
    Dynamic ram: 96312 of which 16 recycled
    Exception stack ram used: 320
    Never used ram: 5948
    Tasks: NETWORK(ready,400) HEAT(blocked,1248) MAIN(running,3540)
    Owned mutexes: WiFi(NETWORK)
    === Platform ===
    Last reset 00:15:43 ago, cause: power up
    Last software reset at 2018-09-10 16:36, reason: User, spinning module GCodes, available RAM 5948 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 22.1, current 33.5, max 34.3
    Supply voltage: min 12.2, current 12.3, max 12.5, under voltage events: 0, over voltage events: 0
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2018-09-11 09:42:02
    Slowest loop: 8.32ms; fastest: 0.07ms
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 37.13ms; fastest: 0.01ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.21
      WiFi MAC address 2c:3a:e8:0b:27:ec
      WiFi Vcc 3.47, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 14304
      WiFi IP address 172.16.28.198
      WiFi signal strength -73dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0
      === Expansion ===

    I'll try another card too


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.