Changing Retraction Acceleration



  • Hello friends,

    I just set up my CoreXY Machine with a DuetWIFI and I begin printing some test pieces now...I have stringing issues and I saw that my retractions are accelerating pretty slow, I have set the maximum E acceleration to 6000 already but it does not speed up with it. Same speed as with 3000. The Retract speed in Simplify3D is 100mm/s and 5mm distance. (E3D Volcano Hotend)
    On my other printer with marlin I can specify retraction acceleration as an own parameter in the firmware and it speeds up with it. so with 3000 acceleration and also 100mm/s at 5mm distance it retracts way faster than my duet machine now.
    Is there any other parameter I have to change in order to get the retracts to accelerate faster?

    Thanks in advance!
    Greetings



  • @brainztorm If you use slicer retraction, then you need to set the retraction speed in the slicer. If you use firmware retraction, then you can set the retraction speed in the firmware. See here https://duet3d.dozuki.com/Wiki/GCode#Section_M207_Set_retract_length. The title of the link is for retraction length but you can alter the speed too by stipulating an F parameter.

    To use firmware retraction, you have to tell the slicer so that it will output G10 ad G11 commands instated of "En" commands. The last time I looked at S3D that wasn'r t an easy thing to do so it might be easier to stick with slicer retraction and adjust the speed in the slicer.



  • @brainztorm It might be that your extruder jerk is limiting the top speed. If you retract 5mm at 100mm/s (ignoring all acceleration and deceleration for a moment) this only takes 1/20th of a second. This is very short amount of time. If your jerk is set too low it might be that the actual reachable acceleration on this short distance of movement is capped.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.