Delta smart effector sensitivity problem



  • Hello
    I have Delta printer installed with delta smart effector and almost more than 1 year i am using it. some how it become more sensitive to vibrations. i set it up to M672 S105💯155 since i use it. after a print i started a new print and i realize that green led is lightning almost all the time. i try to reduce sensitivity but than it hits to hard and bending pcb so i stop trying it. i dont know whats changed. printer works fine no extra viration more than usual. my steppers are working great. dont understand what happened?



  • My Green LED flashes quite a bit during printing. It also works great for auto-calibration, etc.


  • administrators

    Maybe your printer is vibrating more than it used to, or you have increased the acceleration or jerk settings?

    It doesn't matter if the green LED flashes during printing, in fact it's normal. It may also flash while travelling between probe points during bed probing. What matters is that it doesn't trigger prematurely during a probing move.



  • What i mean is i cant do any probes. When i send g32 or g28 or g29 it gives error and says already triggered cant probe. i open the printer and it start to trigger. Nothing move no prints just switch on and it starts to trigger. I reduce sensitivity than it triggers (stop triggering on stand by) but also hits and bends pcb or some arms get loose from magnets. I havent change nothing in the firmware


  • administrators

    Have you made any changes to the heaters or fans on your printer?

    Does the green led flash if you waggle the cable that connects to the 8-pin connector? If so, you may have a bad crimp connection or a fractured wire.



  • Cables are ok. I have checked it. I change heater cable last week it connected directly to the board not through smart effector. Even so printer was working fine until last day. I suspect only one thing. I had clogged nozzle and i was changing it. While i was removing heatsink from pcb i damaged pcb around the nut that holding heatsink. I say damaged but lets say i scrathed a bit pcb



  • @akrepsianka said in Delta smart effector sensitivity problem:

    While i was removing heatsink from pcb i damaged pcb around the nut that holding heatsink. I say damaged but lets say i scrathed a bit pcb

    The actual sensor for the probe is a series of very fine traces on the PCB, spiraling around the center. Where "Spiraling" is triangular.

    Damage to those traces could cause what you are describing. Examine them under a magnifier, or similar.



  • so if they are damaged is it means that my delta smart effector died?



  • @akrepsianka said in Delta smart effector sensitivity problem:

    so if they are damaged is it means that my delta smart effector died?

    Likely Yes.



  • So, I was recently having problems with the sensitivity of my Smart Effector. It would work fine once, and then randomly trigger while probing. Normally it would "finish" the cal, but return useless values. Other times it wouldn't even finish the cal.

    After fiddling with the settings to no avail, I decided that it had to be electrical and I unplugged the hotend cooling fan before attempting the cal. That fixed it.

    I've done at least a dozen Auto Delta Calibrations alternating with Mesh Grid Compensations with no false triggers.

    Hope this helps others.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.