MAC and Static IP on Duet WiFi



  • My network is out of control with 40+ devices. I am going through and systematically assigning static IPs to known devices to help keep things organized and working. Now I'm working on my Duet WiFi powered printers (8 of them) all running the latest firmware.

    I've read the Wiki, the g-code Wiki, and searched lots of posts here. I am using one printer to work through how to set this up to keep it easy. This printer is connected via USB to Pronterface so I can easily check and set things. No matter what I do, the static IP address is not sticking. So I attempted to configure my FIOS router to dole out a static IP to the WiFi. It requires the MAC address of the device - fair enough. I've set the MAC address in config.g as:

    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0x01 ; MAC Address

    Even after rebooting the Duet, clearing network WiFi host networks with M588 S"*" and starting over from scratch, I:

    1. can't get the static IP to stick (using M587 S"ssid" I"my static IP" P"network password"
    2. the MAC address displayed on my FIOS router is nothing like the MAC I've assigned to the Duet with M540!

    I've gone through this configuration multiple times and can't sort it out. Help greatly appreciated! Sleepless in Boston.

    Michael



  • Michael AFAIK you can't set the mac address with M540 on the WiFi's they use the mac that is encoded in the WIFI Module also I have never had any issue with the M587 to do it either mind I have always done it with an empty wifi list so may be worth clearing it out on one and then setting the M587.

    Just a stab but it may just help.

    Doug



  • Thanks. I just did a test and used the MAC I see in my router to config a static IP on the router. That actually worked!

    I had cleared the wifi list as mentioned in my first post. I've tried multiple times! I might remove the M540 from my config and test. But at least I can use my router to assign the static IPs I want.

    Thanks!



  • @mhackney you sure you used M558 S"" to clear the list cos it should be M588 S"" i would then do a M587 to make sure the list was empty but I do know some Routers can be finicky. The M540 by the way goes back to the series 1 duets and the Ethernet version of the Series2.



  • Yes, I used M588 S"*" - I caught the error in your other thread and verified with the g-code wiki. I accidentally typed that above, I'll edit it to reflect.



  • I finally got static ips but not by configuring Duet. I had to set it up on my router using the MAC addresses for my printers. It also required multiple router re-boots to clear out the cruft. I'm not sure why the M587 I"ipaddr" isn't working though. That would be more convenient.



  • The IP does not want to be inside quotes maybe thats the reason


  • administrators

    You have to give the IP address in the same M587 command that you give the SSID and password. This is because you will very likely need to use different IP addresses on different wireless networks.

    M587 will list all the known SSIDs and the IP addresses that it uses when it connects to them, or all zeros to mean use DHCP.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.