Delta - Mesh leveling cumulative error?



  • So I've rebuilt my large delta with a smart effector and am having some issues getting the bed leveled. I run auto calibration and it converges down to .02, which is great. So then I run mesh bed calibration and it shows that I'm high at the Z tower (the mesh points near the Z tower are red in color and say about +.28).

    That is the OPPOSITE of what I mechanically observe with a straight edge, in reality the bed is very slightly angled down towards the Z tower. Maybe half a mm. from center to full +x +y.

    But what I really don't understand is what happens next. If I repeat the mesh bed leveling by running G29 again, the error nearly doubles. And then run G29 a third time, it doubles again. It's like it's either compensating in the wrong direction, or there's something weird with cumulative errors. I figured it would either wipe the calibration table and start from scratch or converge, but it does neither. Eventually after a few runs it thinks I'm several mm slanted which isn't right at all.

    Power cycle, home, auto calibrate, and it's back to exactly the same.

    Any thoughts on what's going on?



  • Ok, I wiped the whole board and started over and it seems like it's behaving properly now. May have had some corruption somewhere or something after all the upgrades (I've been using this board for 1.5 years, maybe old mesh leveling settings were still stuck in the EEPROM). But now it's mesh leveling at less than .1 everywhere (which is good with this bed it's 425mm)


  • administrators

    I'm glad you solved it.

    What type of Z probe are you using? The usual cause of this type of problem on a delta is using a Z probe that is offset from the nozzle, together with inaccuracies in the geometry that cause the tilt of the effector to vary with XY position.



  • I'm using your smart effector. Everything was pretty square so that's why it was so confusing (using those round bubble levels on the effector and bed, etc). Found out that one of my stepper pulleys was skipping occasionally as well (grub screw not tight on the shaft somehow). Seems to be behaving pretty well. I turned off mesh bed leveling as it's not really needed, I managed to print a 350mm diameter circle with just the auto cal.

    Thanks!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.