Y driver issue?



  • Today, I notice that my CoreXY machine (Hypercube Evolution) makes rattle noise on Y motor and it refuses to move properly. It worked fine for past several months.

    Here are things that I tried

    • Swap X/Y motor wirings (I shut the printer down before doing it)
    • Use new cables
    • Test with spare motors on both X and Y drivers
    • Already make sure that connections are stiff
    • Connection on all motors are 100% correct
    • Tested with new motor outside the printer to make sure that belt tension isn't the case.
    • Tried to increase current to 1000mA (from 900mA). (X driver already works fine on 900mA).

    X driver could drives everything normally with all those changes with zero issue. Problem seems to persist on Y driver.

    There is no sign of burnt mark on Y driver and nearby SMD chips . They look just normal as others.

    To not ruins my printing schedule. I use this command to remap Y motor to E1 driver.
    M584 Y4 E3

    Now printer could move all axis normally. Printer is up and running again. But I have to ditch my second extruder plan in the future.

    Here are the questions.

    • Is my Y driver already blown up.
    • I bought this board since February this year. So I assume there is no more warrantee? I already blown one fan mosfet though...
    • Replacing/reflow driver locally seems impossible. I saw Duex2 0.8a is currently on sale. Is this a viable option if I buy this just for extra extruder? Should it be much more economical and way less downtime than asking someone to repair my board?
    • If above option is feasible. Since I'm using BLtouch to probe printer bed and some pin on 50-way connector are occupied. Where will all those pin goes if I choose Duex2 route. I checked the instruction here https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe but I'm too dumb to figure where and how. There is no wiring picture just like normal use case.

    Thank you

    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02RC2(RTOS) running on Duet Ethernet 1.02 or later
    Board ID: 08DGM-95BNL-MGPSN-6J9DL-3S06Q-92WVW
    Used output buffers: 3 of 20 (14 max)
    === RTOS ===
    Static ram: 28460
    Dynamic ram: 98064 of which 0 recycled
    Exception stack ram used: 492
    Never used ram: 4056
    Tasks: NETWORK(ready,328) HEAT(blocked,1232) MAIN(running,3476)
    Owned mutexes:
    === Platform ===
    Last reset 00:33:40 ago, cause: power up
    Last software reset at 2018-10-12 11:59, reason: User, spinning module GCodes, available RAM 4220 bytes (slot 2)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 8
    Free file entries: 8
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.9ms, max retries 0
    MCU temperature: min 56.1, current 58.2, max 58.5
    Supply voltage: min 24.3, current 24.7, max 25.0, under voltage events: 0, over voltage events: 0
    Driver 0: ok, SG min/max 0/195
    Driver 1: standstill, SG min/max 0/0
    Driver 2: ok, SG min/max not available
    Driver 3: standstill, SG min/max 0/50
    Driver 4: ok, SG min/max 0/186
    Date/time: 2018-10-12 12:36:52
    Slowest loop: 6.39ms; fastest: 0.07ms
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 210, MinFreeDm: 136, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 9102, completed moves: 9090
    Bed compensation in use: mesh
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 0 is on, I-accum = 0.0
    Heater 1 is on, I-accum = 0.4
    === GCodes ===
    Segments left: 1
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is doing "G1 X147.341 Y135.220 E3.38633" in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 6.44ms; fastest: 0.03ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8
    Interface state 5, link 100Mbps full duplex
    === Expansion ===

    Config file just in case
    0_1539324837217_config.g


  • administrators

    It does sound as though the driver has failed. You could use a DueX2 as you suggest, or have the driver and the fan mosfet replaced. Forum user W3DRK does Duet repairs in the US and I do them in the UK.



  • Sweet! I will buy that soon. Thanks for your help.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.