G-Code problem with 2 fans



  • Hi there,

    I have a little G-Code question. Maybe anyone could help me:
    I have mounted a second printing fan and I do NOT want to connect them in series or parallel and my pins are like the following:

    heatpipe cooling fan is pinned on a always on fan.
    the 2 printing fans are pinned to fan 0 and 1. (duet location)

    I tried the following: "M563 P0 F1;" because I would like to use my F1 with Fan 0 in combination. I have also found some tool definitions with "M563 P0 D0 H1" and tried to make different changes, but the fans are are not running synchron.

    Could anyone tell me the correct G-Code for my .config?

    Thanks in advance 🙂


  • administrators

    Try appending F0:1 to your existing M563 tool definition in config.g.



  • Hi @dc42,

    Thanks for the quick answer!
    So you mean "M563 P0 F0:1"?

    I will try that later 😉 Thanks so far! 😉

    Is there anything in the slicer configs what need to be added for the "P0" too?

    Have a nice evening

    Regards

    Reckham


  • administrators

    No, that command will delete the existing tool 0 and create a new one with 2 fans but no heaters or extruder drives - which is probably not what you want.

    You don't need to change the slicer configuration.



  • Hi @dc42,

    fixed! The problem was, that Tool 0 manually had to be chosen.
    It does not automatically use the tool 0 or 1, even though there is only 1 tool active.

    This might be a nice suggestion from me as a hotfix for the next software update.
    Would be awesome if you could implement this.

    Thank you very very much for your help! 🙂

    Regards

    Reckham


Log in to reply