Please help with a (I think) dead or deeply asleep Duet 2 Wifi



  • Welcome,

    First of all forgive me for my low level of English, I am using Google Translator to be able to communicate better

    I think my Duet2 Wifi has been damaged. I have read the post https://forum.duet3d.com/topic/791/dead-duet-wifi, I have followed all the steps that are indicated and I have a duet that can not be connected to the Bossa, either I work with Mac.

    To eliminate doubts, I have connected the PanelDue to Bossa and it detects it perfectly, so it is not a problem with cable or connection (I think).

    When the DUET have been connected to USB for a while (I removed the Duet from the printer and there is nothing connected) the WIFI module is heated but Atmel does not

    All 5 LEDs, including the 3.3 (green) and the diagnostic ones, are light and bright.

    The characteristics of the DUET are:
    Duet 2 Wifi ver.1.02
    Firmware 2.02RC2
    DuetWebControl 1.22.3
    DuetWifiServer 1.21

    The Duet is mounted on a HyperCube Evolution (CoreXY) with all motors, fans, extrusion and HOTEND from E3D.

    Since April, Duet has two MOSFET burned due to a defective Chinese fan (bad idea, I know….now) and a negligence. In the middle of a print, I was left without the Hot-end fan and on the way (after a power off- power on cilce) I unplug the fan from the Layer fan and connected the Hot-end fan instead to avoid warming of hotend and possible clog. Result: two burned mosfet, the plastic retainer of the Fan2 connector broked (since I scared with the short) and a fantastic clogged Hotend.

    Although I can’t choose to repair under warranty, is there a chance to revive it?

    The Duet was sent by THINK3DPRINT3D LTD on September 7, 2017.

    I hope that the intention of the message is understood, which will attest to the good work of Google Translator

    Thank you so much
    ![alt text](![image url](![image url](0_1539423643561_Duet Conectada a USB.jpg image url)))


  • administrators

    Some things to check:

    • Which version of Bossa are you using? To program the Duet WiFi you need version 1.8 or later. Earlier versions don't recognise the SAM4E processor.

    • Can you still read the SD card in a PC? If you can't then there has probably been a short or transient on the 3.3V rail, and the main processor has probably been damaged too.

    • Is the 3.3V regulator chip U2 getting hot?



  • @dc42

    thank you so much for your quick answer!!

    I'm using Bossa ver 1.8 because ver 1.9 is incompatible with MacOSx Mojave. As I said, I can flash PanelDue with no problem so I think there is no problem in this side.

    The SD card is perfectly accessible from the computer. This was the first check I made when detecting the problem

    The 3.3v voltage regulator is not heated after 30 minutes. The WIFI module is hot and the Atmel is slightly heated, but less than the WIFI module.


  • administrators

    Do you know what triggered the problem?

    As the SD card is OK, I think the most likely causes of the problem are (in no particular order):

    • Bad soldering between the USB socket and the PCB, or the processor USB pins and the PCB, or just possibly the USB series resistors and the PCB
    • Bad contact in the USB socket
    • Failed processor

    It's possible to replace the USB socket and the processor.



  • @dc42

    David,

    I don't know what was the trigger of the problem. The printer was at mid print when the power supply stopped, it is driven with a relay. The PanelDue showed the message "Connecting" and all the values and readings were at 0. I could not access with the Browser at the page of the Duet. I removed the SD card and tried it on the computer. There was no problem and no file corruption at all. I Backup the files in a folder of my computer without error and I can access to the text format files (config.g, bed.g...)

    This afternoon I will look at the welds that you proposed to see if I see something, but I do not think that the stoppage in the middle of printing was due to a defect in welding. So everything points to the problem being the processor.

    When I can look at it I will write again.

    Thank you for your attention



  • @dc42

    I tried with the multimeter the continuity between the end of a USB cable connected to the Duet and several points in the Duet's PCB around the USB connector (R1, R2, ...). I have found continuity between the four cables of the USB connector and the points that I have mentioned. The cables have been tested individually.

    I think this discards a bad welding of the USB connector to the PCB.

    Regarding the USB pins of the microprocessor and the resistors, I do not know how to measure it. I have taken a picture of the microprocessor pins and I have not seen anything strange, but that does not rule out anything.

    Thank you again


Log in to reply