Network card of Duet 2 Ethernet doesn't work



  • Hello,

    I've just received my Duet 2 Ethernet. When I connect it to the network, no led turn on. I tried multiple ports, multiple switches, and directly on my desktop computer. In all cases I'm not able to establish a link. I've also tried to force the speed to 100M or 10M, and to disable auto-negotiation, with no luck either.

    All the connections should work (tested with a computer, and a PocketEthernet).

    The only way I've found to have the led turn on is to connect directly the PocketEthernet to the Duet and to run a link test (it blinks quickly in orange and the PocketEthernet says that there is a 100M FD MDIX device connected).

    M115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.0(RTOS) ELECTRONICS: Duet Ethernet 1.02 or later FIRMWARE_DATE: 2018-06-05b3
    ok
    M552 S0
    Network stopped
    ok
    M552 S1
    ok
    

    When I connect directly to the PocketEthernet, I get:

    Network running, IP address = 192.168.1.14
    Network running, IP address = 192.168.1.14
    

    The issue is the same whether I power the board by USB or by a 24V lab power supply.

    Any idea how to fix this issue? I would prefer not to send back the Duet, since the post/customs are very expensive here between Switzerland and GB...

    Thanks,

    PS: engineer here, I'm willing and competent to diagnose the issue


  • administrators

    The LEDs on the Ethernet socket should turn on if you send M552 S1 and the Duet is connected to another Ethernet device. They won't turn on if you haven't enabled networking by ending M552 S1, either manually or in config.g.

    The fact that both the Pocket Ethernet and the Duet report that a link is established when they are connected suggests that the Duet is working. Can you ping the Duet from the Pocket Ethernet?



  • Thank you very much for the quick reply, very appreciated 🙂

    I was able to ping the duet from the PocketEthernet. Meanwhile I was able to find a switch which the Duet "likes" enough to communicate with.

    For now, I'll use this one... but still IMO it would require some investigation why it doesn't work with every other ethernet device I tried?


  • administrators

    Might you have been using a crossover Ethernet cable? The Duet doesn't automatically switch its pins to suit the cable, and perhaps the switch you were using doesn't either.



  • Every device I'm using supports auto MDI-X, and I tried with different cables.

    If I get my hand on a ethernet analyzer, I will investigate this issue further and keep you posted.


Log in to reply