Died my Ethernet Module?



  • Hi,
    yesterday evening my Duet3D Ethernet board (V1.03) lost its internet connection.
    It worked now for 4 weeks pretty well (controlling via web access), but since yesterday I don’t have any access to the board:
    1.During some motor tests (all of them worked – no electrical problem) I lost the connection between Webbrowser and the board several times –
    after switching off the 24V power supply, it rebooted and the connection established again. After 10 min and sveral (successful) reboots, the board disappeared completely. Both LED’s on the HanRun connector are off.
    2.When I connect the board via USB with my computer the 7” display shows the normal surface and accepts input, but nothing happens.
    3.The IC on the Ethernet extension boards gets really hot, even with a 5V USB connection to my computer. Is this normal ?
    4.I can establish a USB connection between my computer and the board via YAT – but M115 doesn’t give any response
    Can you please help me to solve the problem ?


  • administrators

    First, if you have M552 S1 in config.g to start the network, try removing it, to see if you can get a USB connection when the Duet starts up with networking disabled.

    If that doesn't work, you could try removing the Ethernet module. It plugs into a socket on the main board and is held in place by three standoffs. Without the Ethernet module, the firmware will think it is a Duet WiFi, but that shouldn't matter if there is no M552 S1 command to start the network.

    Check whether the green 3.3V led is illuminated while you do all of this. If it isn't or it is dim, then something (with luck, just the Ethernet chip) is overloading the 3.3V rail, and the U2 regulator chip on the main board will get hot too.



  • Wow, that's fast !!! Thank you for your reply !!
    Well, I disabled M552 S1 in the config.g and got a reply on M115 ! see picture0_1539807630340_M115Reply.JPG
    The green 3,3V LED is on all the time , but there is still no reaction on M552 S0 in YAT and no LED on the HanRun Connector.0_1539808246760_M115Reply_02.JPG


  • administrators

    Do you lose the USB connection when you send M552 S1 ? If so then the Ethernet module is dead. If your Duet is out of warranty, you can buy a new module from the Duet3D web shop. I think Filastruder sells them too.



  • same with the Ethernet DHCP connection - no answer from the board and no LED on the connector.0_1539808742087_M115Reply_03.JPG
    0_1539808802344_IMG_6629.JPG



  • Yes, after M552 S1 YAT looses the USB connection ☹



  • Thank you for fast and competent help !!! 👏 I'll try to get a new one.


Log in to reply