Auto bed compensation / Manual bed leveling assistant



  • Good evening,

    I set up my config.g and bed.g according to this manual:
    https://duet3d.dozuki.com/Wiki/Using_the_manual_bed_levelling_assistant

    part in config.g:

    ; Manual Bed leveling assistant prerequisite
    M671 X-4:302:302:-4 Y-4:-4:300:300 P0.5
    

    bed.g:

    M561                ; clear any bed transform
    G28                 ; home all axes
    ; Probe the bed at 4 points
    G30 P0 X15 Y15 H0 Z-99999
    G30 P1 X285 Y15 H0 Z-99999
    G30 P2 X285 Y285 H0 Z-99999
    G30 P3 X15 Y285 H0 Z-99999 S4
    

    It should probe front left, front right, rear right, rear left.
    My origin is set to the front left.

    After the homing with G28 (in the bed.g), the head doesnt probe the first point at 15/15 (that's also the z homing position) but it tries to drive the printhead against the limits (like it wants to probe outside the bed).
    Therefore, the G32 command fails in the end.
    Are my config set up correctly? Am I missing anything?

    Additionally, this is my homeall.g, if it helps:

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Jul 15 2018 21:09:13 GMT+0200 (Mitteleuropäische Sommerzeit)
    ; home X
    G91                     ; relative positioning
    G1 Z5 F6000 S2          ; lift Z relative to current position
    G1 S1 X-305 F1800	; move quickly to X endstop and stop there (first pass)
    G1 X5 F6000       	; go back a few mm
    G1 S1 X-305 F360        ; move slowly to X axis endstop once more (second pass)
    G1 X5 F6000       	; go back a few mm to prevent running the motor into the Y endstop mount
    
    ; home Y
    G1 S1 Y305 F1800 	; move quickly to Y endstop and stop there (first pass)
    G1 Y-5 F6000       	; go back a few mm
    G1 S1 Y305 F360        ; move slowly to Y axis endstop once more (second pass)
    G1 Y-5 F6000       	; go back a few mm
    
    ; home Z
    G90                     ; absolute positioning
    G1 X15 Y15 F6000        ; go to first bed probe point and home Z
    G30                     ; home Z by probing the bed
    G1 Z5 F100 S2          ; uncomment this line to lift the nozzle after homing
    

  • administrators

    If the bed is a long way off level, you may need to increase the dive height. That's the H parameter in the M558 command.



  • @dc42
    The bed doesnt get probed after the G28 in bed.g, that's the issue. After the homing, the x/y axis goes total nuts. I'll make a video when I get home



  • @royce said in Auto bed compensation / Manual bed leveling assistant:

    @dc42
    The bed doesnt get probed after the G28 in bed.g, that's the issue. After the homing, the x/y axis goes total nuts. I'll make a video when I get home

    You mention a G32 command but I don't see where it is.

    Frederick



  • @fcwilt G32 initiates the bed leveling assistant. It's the command that @Royce sends manually to get the bed.g to start running.



  • @garyd9 said in Auto bed compensation / Manual bed leveling assistant:

    @fcwilt G32 initiates the bed leveling assistant. It's the command that @Royce sends manually to get the bed.g to start running.

    Thank you.

    Frederick



  • Can you post your full config.g?

    I'm curious how your Z probe is configured.

    Did you get your 0,0 origin set to the front left?

            Y300
    X0                X300
            Y0
    

    Does a normal G28 on it's own home all axis properly?

    Rather than manually probing 4 points with Bed.g, why not try using mesh grid compensation (G29) with a sparse grid instead? A 300x300mm bed with a 100mm grid spacing would give you a similar results.


  • administrators

    @royce said in Auto bed compensation / Manual bed leveling assistant:

    @dc42
    The bed doesnt get probed after the G28 in bed.g, that's the issue. After the homing, the x/y axis goes total nuts. I'll make a video when I get home

    It sounds to me that you have some old deployprobe.g and retractprobe.g files in /sys on the SD card. Delete them.


Log in to reply