How to stop debugging



  • When i connect to repetier host or YAT, the debugging messages are flooded.

    03:55:58.264 : FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.01(RTOS) ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2018-07-26b2
    03:55:58.276 : T:28.8 /0.0 T0:28.8 /0.0 B:2000.0 /0.0
    03:55:58.276 : X:0.000 Y:0.000 Z:370.377 E0:0.0 E1:0.0 E2:0.0 E3:0.0 E4:0.0 E5:0.0 E6:0.0 E7:0.0 E8:0.0 Count 53883 53883 53883 Machine 0.000 0.000 370.377
    03:55:58.276 : serial: T0
    03:55:58.276 : serial: M20
    03:55:58.276 : GCode files:
    03:55:58.276 : "test.g","20mmTestCube_repaired.gcode","3DPNFilHoldGuide.gcode","3DPNFilHoldRoller.gcode",
    03:55:58.276 : serial: M105
    03:55:58.276 : T:28.8 /0.0 T0:28.8 /0.0 B:2000.0 /0.0
    03:55:58.276 : serial: M111 S6
    03:55:58.522 : New conn on socket 0 for local port 80
    03:55:58.522 : HTTP connection accepted
    03:55:58.522 : Found responder
    03:55:58.522 : Received 401 bytes
    03:55:58.523 : HTTP req, command words { GET /rr_status HTTP/1.1 }, parameters { type=2 }
    03:55:58.526 : Sending JSON reply, length 1196
    03:55:59.537 : New conn on socket 0 for local port 80
    03:55:59.537 : HTTP connection accepted
    03:55:59.537 : Found responder
    03:55:59.538 : Received 401 bytes
    03:55:59.539 : HTTP req, command words { GET /rr_status HTTP/1.1 }, parameters { type=1 }
    03:55:59.541 : Sending JSON reply, length 593
    03:56:00.541 : New conn on socket 0 for local port 80
    03:56:00.541 : HTTP connection accepted
    03:56:00.541 : Found responder
    03:56:00.541 : Received 401 bytes
    03:56:00.542 : HTTP req, command words { GET /rr_status HTTP/1.1 }, parameters { type=1 }
    03:56:00.543 : Sending JSON reply, length 593
    03:56:01.529 : New conn on socket 0 for local port 80
    03:56:01.529 : HTTP connection accepted
    03:56:01.529 : Found responder
    03:56:01.530 : Received 401 bytes
    03:56:01.531 : HTTP req, command words { GET /rr_status HTTP/1.1 }, parameters { type=1 }
    03:56:01.533 : Sending JSON reply, length 593
    03:56:02.520 : New conn on socket 0 for local port 80
    03:56:02.521 : HTTP connection accepted
    03:56:02.521 : Found responder
    03:56:02.521 : Received 401 bytes
    03:56:02.522 : HTTP req, command words { GET /rr_status HTTP/1.1 }, parameters { type=1 }
    03:56:02.524 : Sending JSON reply, length 593
    03:56:03.534 : New conn on socket 0 for local port 80
    03:56:03.534 : HTTP connection accepted
    03:56:03.534 : Found responder
    03:56:03.534 : Received 401 bytes
    03:56:03.535 : HTTP req, command words { GET /rr_status HTTP/1.1 }, parameters { type=1 }
    03:56:03.537 : Sending JSON reply, length 593
    03:56:04.533 : New conn on socket 0 for local port 80
    03:56:04.533 : HTTP connection accepted

    When i enter gcode M111 S0, it stops but after reconnecting it starts again.

    How can i stop this from recurring always?



  • Do you have logging turned on in config.g?


  • administrators

    Repetier host assumes that it is connected to Repetier firmware; and because Repetier firmware uses the P parameter of the M111 command to do something other than the specification in the reprap.org GCodes wiki, it ends up turning debugging on. I recall that some time ago Repetier told me they were going to make some changes to Repetier Host to make it more compatible with RepRapFirmware, but I don't know whether they ever did that.

    With YAT there shouldn't be a problem, unless you have enabled debugging in config.g using a M111 command.



  • No, i have not enabled debugging, there is no M111 command in my config.

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Oct 05 2018 00:31:02 GMT+0530 (India Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare

    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    M665 R258 L398 B140 H377 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 PSPARX3D ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M584 X0 Y1 Z4 E3 ; Apply custom drive mapping
    M350 X16 Y16 Z16 E16 I0 ; Configure microstepping without interpolation
    M92 X80 Y80 Z80 E100.48 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1000 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Endstops
    M574 X2 Y2 Z2 S0 ; Set active low endstops

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H10 F120 T3600 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X-23 Y9 Z1.244 ; Set Z probe trigger value, offset and trigger height
    M557 R140 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4388 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H0 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool
    M501

    I think the problem is with repetier host, when i first make a connection with YAT , there is no debugging messages after when i connect it to repetier the debugging starts and restarting the YAT connection the debugging messages are continued until M111 S0 command is given.


Log in to reply