New Duet Wifi - Wifi module issue, endstops not working?



  • So i got a new Duet wifi, but 9/10 when it boots either after reset, power off the wifi module fails to come online. My definition for online is the blue light flashes while connecting to the AP, it either stays solid or stops which is fine if it cannot connect.... But in this case it doesn't come up until multiple-resets. Rarely it comes online first reset/startup from power off. So when saving configuration to emergency stop i have to constantly reset it again... and sometimes i have to do it up to 5-10 times before it decides to start trying to connect.

    When it connects, it works fine though.

    In addition to that, all end stops from Z to E0 seem to always report a single state dependant on the configuration, Hit or Not Hit. no response/action from the endstop, they never appear to work. Far as i know mine are NC with ground as the signal.

    Aside from that, i configured sensorless homing and a BLTouch on it and works flawless and everything else seems fine but the Wifi issue and endstops bug me since this is a new new board. if i'm away from the machine and it needs a reset, there is maybe a 90% chance it won't come up.

    It's still on the shipped firmware which is the V2.0 RTOS version.

    the Config.g seems pretty typical from the configuration generator and has the Enable Network command and usual setup at the start of the file so not sure what it could be unless i need to re-flash the Esp8266. it might very well boot if i retried from the serial/USB console but issue is having it work on a reset or power up.... it's just unstable.

    I'm trying to determine if it's a known issue or if i should just return it for another one since the endstops appear DOA.... i still have to check if there is indeed voltage on the endstops. maybe a fuse is popped?

    Thanks.



  • Can't edit? but added note, the 3.3v and 5v power lights come up fine..... USB or 24v powered seems the same either way.



  • https://duet3d.dozuki.com/Wiki/WiFi_disconnections_and_AJAX_timeout_errors

    here's some trouble shooting you can go through to eliminate things.



  • i've looked, it's a bootup issue. It never event attempts to connect 90% of the time... i have to manually reset a few times in a row before it even tries to connect to get to that point... but 100% of the time when it does TRY to connect it connects fine with zero issues. It's almost like the module isn't getting turned ON when it should. maybe a SD card issue, no idea...



  • Have you tried upgrading your main firmware and wifi firmware versions?

    When you are connected to the wifi, run a M122 in the console to get a diagnostic report, copy and paste it here.

    Have you tried clearing the list of wifi networks and readding it?

    If unable to connect to your wireless network at boot up, try deleting all saved wifi networks with M588 "*" (That is, using an asterix for the network name), then re-adding it with M587. For example, M587 S"networkname" P"password".


  • administrators

    Try flashing the current version of DuetWiFiServer and updating main firmware to 2.02 or 2.03RC3. If those don't fix it, ask for your Duet to be replaced.


Log in to reply