Robo3d R1 Plus AutoLevel



  • zprobe 0 (or the first picture) is without me lifting and activating the trigger. Z probe 100 is when i trigger it by hand.


  • administrators

    @sleepless said in Robo3d R1 Plus AutoLevel:

    zprobe 0 (or the first picture) is without me lifting and activating the trigger. Z probe 100 is when i trigger it by hand.

    I presume you mean it reads 1000 when you trigger it by hand. As it also reads zero when you don't trigger it, your Z probe seems to be configured correctly.

    You've mentioned two problems:

    1. "X axis seems to crash". Do you mean that it is driving into the hard endstop? If so then I think you need to adjust the X parameter in your M208 S0 command. The X2 parameter in your M574 command indicates that you are homing X to the high-X (which I presume is the right hand) end of the axis, and your M208 S0 X parameter is 230. So when the endstop switch triggers, it will set X to 230. I think you need to reduce that 230 value so that after homing, if you send G1 X0 F1000 then it moves the head to the left hand edge of the bed. Or, if it can't reach the left hand edge of the bed because it hits the hard endstop first, you want it to move to a point a few mm before it hits the hard endstop. See https://duet3d.dozuki.com/Wiki/Centering_the_bed_or_setting_the_bed_origin for more.

    2. If it prints too close to the bed, then you need to make the G31 Z parameter more negative than it already is. For example, if you change it from Z-1 to Z-1.1 then your prints will start 0.1mm higher.

    However, I am concerned that in the video you posted in the other thread, when you probed at the left or right hand edge of the bed, the bed tilted rather a lot. This leads me to believe that the trigger height may be a lot more negative at the edges of the bed than in the centre. If that is the case, then you may need to change the M557 command to restrict the mesh to a smaller area of the bed.

    You might like to send a direct message to the author of the thread https://forum.duet3d.com/topic/4737/zprobe-robo3d-r1/9 to ask him if he can share his config.g and homing files with you.

    HTH David



  • Yes the z probe reads 1000 not 100. Sorry for now being nore clear the x axis crashes into the end of the rail opposite of the endstop. Usually dies this right before a print starts. I will use your recommendation and adjust the settings fir this.
    Your concern. About the probing of the bed is valid as its a problem that plaugues the robo3d r1 plus. I will manual level it again to try to ease this a bit.
    I have tried contacting the author of that thread but havent heard back.



  • Just to clarify... All axis home properly.
    The x axis crashes into the left of the gantry before beginning a print. or when I run this
    " G1 X0 F1000 then it moves the head to the left hand edge of the bed"



  • The auto level is not going to the back of the bed here is a video( you can fast forward to 1min 40sec) https://www.youtube.com/watch?v=NDrzoygZaHA



  • I fixed the X axis cashing issue... Problem was in the gcode, G1 X0 instead of G1 X15. Now it no longer crashes.


  • administrators

    I'm glad you managed to fix it. Are the problems you reported at the start of this thread resolved now, or do you still have a problem with Z probing?



  • Itstill does not go to the back of the bed for auto level everything else is ok for auto level. Now I am having issues with the heated bed causing prints to cancel but I will start a new thread fro that problem


  • administrators

    The reason it isn't going right to the back is that it will omit any probe points that would put the nozzle outside the reachable area set by your M208 commands. Assuming that the back of the bed is max Y, you may need to increase your M208 S0 Y parameter a little to that the nozzle can move as far back (or the bed as far forward) as physically possible.



  • Thanks ill give that a try



  • I am still having some issues. It is printing too high in the front right to middle right of the machine. Everything else is a perfect layer. I was wondering If there is something I can do to fix this?



  • Get a proper Z probe and use mesh grid compensation.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.