Tevo Little Monster converstion - Printing/Zprobe issue?



  • Hello again,

    I am slightly stuck, I have read the gcode wiki and watched a you tube video on the conversion of this printer. To be honest the mechanical part was straight forward but the config leaves me somewhat confused. I followed the article on the BLTouch and this helped wire it up and get it to function tremendously.

    But now I am getting confused 😞

    Steps so far:

    The probe works fine, it deploys measures the bed and then will probe the area to create a grid. This has been consistent for the past 3 days. Today all three axis towers homed perfectly, then did the initial probe (G28). It went to build the grid and put the nozzle into the glass as the probe did not trigger.

    When the probe was working the printer did start to print, and at this I am confused as the printer seemed to be printing at the wrong height, like it was out by 5mm or so.

    Any help would be greatly appreciated. I have looked at the documentation and cannot understand what I am missing.

    Best regards

    Andy 🙂

    Config.g

    ; Configuration file for Duet Ethernet (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon May 22 2017 22:56:20 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    M665 R155 L397.19 B155 H520 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Define active high microswitches
    M558 P1 X0 Y0 Z0 H5 F500 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    M557 R150 S30 ; Define mesh grid

    ; BL-Touch
    M307 H3 A-1 C-1 D-1 ; reserve pin 21 for M42 or servo use
    M558 P9 H3 F1200 T5000 ;P9 is a key BLTouch Value
    G31 P25 X0 Y20 Z1.5 ; Set Z probe trigger value, offset and trigger height
    M557 R150 S30 ; Define mesh grid

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 E32 I0 ; Configure microstepping without interpolation
    M350 X32 Y32 Z32 I1 ; Configure microstepping with interpolation
    M92 X160 Y160 Z160 E837 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X1500 Y1500 Z1500 E1500 ; Set maximum speeds (mm/min)
    M201 X1500 Y1500 Z1500 E1500 ; Set accelerations (mm/s^2)
    M906 X1800 Y1800 Z1800 E1500 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S285 ; Set maximum heater temperature to 285C
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4607 C8.950070e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PTEVO Little Monster ; Set machine name
    M540 PBE:EF:DE:AD:FE:ED ; Set MAC address
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S0 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory



  • Hello,

    So I had a chance to do some more testing and refine what I am actually doing and what is not working.

    1. Turn printer on

    2. Connect via Ethernet

    3. Home printer - this also started failing again (despite my earlier report of successes). It has failed only twice since and usually over larger distance distance.

    4. home again just to be sure

    5. issue command G01 Z5. this sends the 3 towers to a Z height of zero. Currently its not...so use a piece of paper to drop the z till it gets too 0

    6. Use G92 Z0 to set the Z height

    7. Go to Z10 and find the trigger height of the probe using G30 S-1

    8. Change the line in the config.g to reflect point 7's value

    9. Run auto calibration, which homes fine

    Auto calibrate tries to touch off the probe and never makes it to the bed, resulting in a failed trigger error.

    Having set the Z to 0 and checked the probe trigger height, I am somewhat confused. Any help would be greatly appreciated.

    Andy 🙂


  • administrators

    When doing initial auto calibration on a delta, you should set the dive height (M558 H parameter) to a high value such as 30, to allow for your initial delta parameters being inaccurate. See https://duet3d.dozuki.com/Wiki/Calibrating_a_delta_printer.



  • Wow!

    Such a simple change. This seems to have cured the issues, there were other problems as I also found that my slicer gcode was affecting the Z height.

    I am now printing 🙂 Lets see what happens I have a test cube running but will take a little time as its 100mm x 100mm x 21mm

    Thank you,

    Andy


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.