Delta going haywire only sometimes, SOLVED.



  • I posted a question in here back in August about why my delta went haywire when trying to print above a certain radius.

    I told my friend what to look at and after a long while he finally got around to fixing it.

    It was the "B" Parameter in the M665 in...I want to say the config override file. I likely manually put this final M665 line in after a very thorough manual calibration. The thread was locked for some reason and I wanted to update it saying "SOLVED" but I wasn't allowed to, so I'm creating a new one to say it was solved and what the solution was.

    My original post was here should people ever need have a similar problem:

    https://forum.duet3d.com/topic/6466/why-would-my-delta-do-this

    Does this still happen in newer firmware? If you try printing larger than this, the g-code should simply be unreadable. Is there a way to implement into my own configurations to "simulate gcode" prior to each and every print to verify whether any read errors occur or any movements outside of the minima and maxima (or printable minima and maxima) for each axis?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.