[SOLVED] Part-Fan not running



  • Hi,

    I suddenly have a strange problem. My component fan is connected to FAN1 (And remapped Heater). So I have:

    M106 P1 S0 I0 F500 H-1 C "Part2-FAN"

    and

    M563 P0 D0 H2 F1 S "Smart-E3Dv6"

    specified.

    The fan runs when I switch it on via M106 S1 or M106 S255 via WebIf.

    But as soon as I do the whole thing in the GCODE (created by Simplify3D) the fan doesn't move.

    It's interesting that the PanelDue is set to 0% for the FAN and I can't overwrite it.

    According to the web interface the fan "runs".

    I use the Smart-Effector and so far everything works.

    The GCode also shows it correctly.

    Startup.GCode:

    T0 ; select tool 0
    M140 S[bed0_temperature] ; set bed temperature
    M104 S[extruder0_temperature] ; set extruder temperature
    M116 ; wait for temperatures to be reached
    G29 S1
    G4 P2000 ;pause for paneldue
    G28 ;home
    M564 S0 ;disable movement limits
    G1 Z15 X0 Y-175 F3000 ;move to front
    G1 E20 F100 ;extrude 20mm slowly
    G4 P1500 ;pause
    G1 Z5 X0 Y0 F6000 ;move down to swipe filament off
    M564 S1 ;enable movement limits
    G1 Z0.2
    G92 Z0

    Used Hard- and Software:

    Softwareinformationen
    Firmwarename: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Elektronik: Duet WiFi 1.02 or later + DueX5
    Firmware Version: 2.02RC3(RTOS) (2018-10-17b2)
    WiFi Server Version: 1.21RC5(16b1)
    Web Interface Version: 1.22.4-b1

    To make a long story short:

    Sending M106 S255 via WebIF -> Works
    Sending M106 P1 S255 via WebIF - Works

    Gocde:

    Sending M106 S0 -> Works
    Sending M106 S255 - Not working
    Sending M106 P1 S255 -> Not working

    Any ideas?

    Cheers
    MoS-tekknix



  • Update:

    Even with fit the Part-Cooling-Fan to P0 (Fan 1 on Duet) will not really help. The same will happen.

    Part-Cooling Fan can be changed via Panel-Due and WebIF, but in gCode no change.

    I'm out of ideas and my head is spinning around...


  • administrators

    This is very strange because there should be no difference in how M106 S255 is handled no matter where the GCose command comes from. Please can you test it with a small GCode file containing M106 commands (with no P parameter). Note, you must have Tool 0 selected for the print fan mapping toi take effect.



  • Hi David,

    shame on me. After digging completely thru the Setup again and again i've found out that it belongs to my Heatbead and the Haydn-Rods.

    The 24v 40mm Part is the culprint. After losing it from the Effector (and let him hand around) i've homed my Delta and set the Fan manually on to 100%. Everyhting works as expected.

    Send a G1 Z5 to let the Printer down from 647 to 5mm and in the middle of it the Fan stops. Via Panel-Due raised Z and bamm, it starts running again aroun Z beeing 340...

    Even if the Heatbed isn't on, it seems that the Aluminium Plate (350mm) together with the Haydn-Rods intruduces a very bad magnetec-Field for such Parts.

    The delivered Standard 30mm Fan from E3D which belongs to the Smart-Effector will run without any problems (which were more problematic as the Part-Fan).

    Unfortunatelly i've only 5 of the same Fans (40x40x10mm and 24V), therefore i need to switch over to my Due5 and use the 12V-Fanoutput to test different fans.

    Sidenote: My 5015 Radial-Blower (which will not reaaly fit) doesn't suffer from this Magnet-Field...

    Do you have any kind of ideas other as testing different Fans?

    Regards
    MoS-tekknix


  • administrators

    Did you follow our recommendation to install the rods with alternating magnetic poles around the effector? This usually solves that problem.

    If that doesn't work, you could install short spacers between the ball studs and the PCB, to keep the rod ends at a greater distance from the fans.



  • Yes, have done them in correct Order (first they are labeled and additional you can check it if you put them together). I've changed them too.

    Even if i put the Rods away from the Fan-Connector it will stop running at the same height.

    I've found another spare 24v 40mm Fan and it looks exactly the same. I'll change it to Duex and try with some branded Fans. These cheap Chinese-Fan's drives me nuts



  • No chance.

    Even with a high branded Noctua on 12V it will still stops at the same height. That is crazy. Can i bump the Frequency up?



  • Will measure the Voltage going out of the Connector.



  • Running Fan 11.8579V

    Going to the Height where the Fan will not be running anymore:

    Voltage 0.1852V

    So the Motor will not stop due to magnetic field the Smart-Effector will not power the Fan anymore.

    Any thoughts David? That is unusual.



  • Put Fan0 directly to Duet, Fan5 to the Effector. And running Tool with Part-Fan 0:5 and it will at least not come from Duet, cause if the Problem happen, Fan0 will still run but Fan5 will stop.



  • Further Test:

    Even if i remove the Haydn Rods and hold the effector in my hand. As soon as a go down the Fan stops.

    Will now try to put a long cable from FAN0 Port on Duet to a further Fan without connecting it to the Effector and try if this makes a difference. But i'm somehow running against a wall...


  • administrators

    @mos-tekknix said in Part-Fan not running:

    Further Test:

    Even if i remove the Haydn Rods and hold the effector in my hand. As soon as a go down the Fan stops.

    If it's sensitive to position, it sounds like a bad crimp connection in the fan cable to me, or possibly bad soldering where the 6-pin connector is soldered on to the effector PCB. Does the soldering look OK? Can you make the fan turn on and off by waggling the cable?



  • Will try. Using iwiss Crimp-Tools all the time and never have had a bad crimp. Thanks for getting back.



  • Have waggled as hard as i can, no difference. As expected the Crimps are good enough.

    Anyhow, i've resoldered the PF+ and PF- Connection. It's getting better, cause now i can lower Z additional 20 Centimeters before the Fan will shutdown.

    Will at least try a longer cable without the 6pol Connection to get the fan running. If this will work, i know at least that this is more a less a problem with the Terminal. Maybe i'll solder it out and replace it with something different.


  • administrators

    Did you check visually the soldering of the 6-pin connector on the underside of the Smart Effector?

    When crimps fail, sometimes it's due to a wire fracture inside the cable close to the crimp, or a pin not locked into the shell. In such cases, pushing the cable down into the connector is sometimes what makes the connection again temporarily.



  • Indeed it will be the Terminal. Putting in a Fan directly with a longer Cable directly to Duet will work everytime. The Connection looks somehow okay but i never trust flux. And without calling me hero, i'm doing crimping mostly every day and my tools are great. Never had a failed Electronics due to bad crimping. And after resoldering a little bit it is getting better.

    Later, if i'm able to spent the time, i'll completely resolder the Terminal.

    Thanks so far David.



  • Have to correct myself. It's not the 6Pin-Terminal. Have soldered the Cable directly to the 2Pin-Connector of PF+ and PF-.

    Here the Problem exists. It seems that here exist a problem. As said, have now used a Long-Cable and run the Fan0 directly. No more issues.

    Cheers



  • A further Check seems that the Effector is the Problem here.

    Now, i've tried again the Calibration of my Delta and whoops. The Effector triggers itself around the same Height, as the Fan goes out before!

    Is there a Way to "Reset" the Effector in same way? Currently it triggers at a Z-Height of 100mm!



  • My Printbed will introduce a big magnetic Field above 48°C ....

    Therefore only Option is to use B1 in the M558-Command ...


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.