DuetWebControl Update Help



  • Using duet wifi(not the latest, board says v1.01)
    Using Mac computer

    Disclaimer: this is a long post, but wanted to make sure i hit everything to cut down on as many back and forth questions and answers. Just wanting to give as much detail as possible.

    I unfortunately wasn't able to print anything for the last year and a half, but just got back at it. I was on firmware 1.17, and couldn't even remember how i used to get to the wedcontrol. So I got started at https://duet3d.dozuki.com/Guide/1.)+Getting+Connected+to+your+Duet/7?lang=en, realized i needed to update my system.

    So went to the how to update link https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware#Section_Updating_WiFi_firmware, and worked my way through it. Saw i needed to do the firmware first, wifi server, then web control all in order. Got the files from https://github.com/dc42/RepRapFirmware/releases. I noticed all the ones at the top says V2, so I'm assuming its for the newer boards. I scrolled down to the newest one that doesn't have V2 next to it, which is 1.21. I downloaded all 3 files needed.

    I updated the firmware via bossa due to my frustration along the way and deciding to hit the erase button(tho everything else stayed, not sure if normal) But send M115 in Printrun shows I'm indeed on 1.21, yay. I can't get the webcontrol up, so i take the SD card out and connect straight to computer, bring the wifiserver file onto sd, then reinstall sd card in Duet wifi. I then use M997 S1 to update the server update that i installed the wifi server, and yay another success.

    So now to the webcontrol. the file that you download is a zip file that actually saves as a folder... On the hot to page it says ""If the web interface is not working, then move the SD card to a PC, delete or rename any existing /www folder, create a new one, and extract the contents of DuetWebControl.zip into it. Do not unzip the individual .gz files, leave them as they are on the SD card."".

    First question seeing as how I'm not able to get the webcontrol up, do i just bring the whole duetwebcontrol file over the the SD Card?With out any changes?where does it get placed? What /www folder because i have no /www folder on SD card, or hell not even my computer? "Extract the contents of DuetWebControl.zip", after downloading its saved as a normal folder on my computer, so can extract i don't think.

    Ive actually compressed the duetwebcontrol folder to turn it into a zip file, and kept the original folder. I moved both over to the SD card. I even created a /www folder with the zip file. I also in the sys folder(because thats where my original duetwebcontrolBIN file was/is put the original duetwebcontrol folder from the download, and another zip version in there. All this of course after many tried other way.

    Okay, so with the card back in the machine i send M997 S2 to get the webcontrol to update, but all i get is"M997 S2
    SENDING:M997 S2", never any progress. After waiting forever multiple times i realize this isn't working, try other thing but can't find an answer:/. I eventually send M587 S”wifi24” P”password” to see if i can get it going either from the old webcontrol firmware or the new(both are on the SD card). But i get the message
    M587 S”wifi24” P”password”
    SENDING:M587 S”WIFI24” P”RICKJAMES”
    M587: Bad or missing parameter.

    Ive actually learned how to write exe files on a mac, wrote macro for the M587 S”wifi24” P”password”, put it in the macros folder. Sd back in, in print run send M98 P/macros/(macro file), but get the same bad or missing parameter. Ive tried the M587 in so many ways my mind hurts. BUT whats strange is I can send M587 and it list the networks(I've got a few) that i tried connecting too. All have 0.0.0.0 for IP,GW,NM. I assume that may indicate its automatically assigned those, so i try to get the ip to enter into address bar, but can't find one, so i enter http://duettest.local/''' which doent work. I then at some point in all this try M552 S1, but i get
    "m552 S1
    SENDING:M552 S1
    WiFi module started
    WiFi module is connected to access point wifi24, IP address 10.1.10.209"
    This is strange, i didn't send M552 S2 to put it in access point(which I'm not even sure the reason for this is), but M552 S1 won't revert it, M588 doesn't forget the network so i can try again. its just stuck in access point and I'm not able to still get into web control.

    SO by all means, any help would be greatly appreciated. Clearly my problem at least is starting from me not knowing what to do with the duetwebcotrol file, and I'm guessing is preventing me from moving forward. And please try not to talk down to me, been a long day and night. I haven't been able to mess with my printer in a very long time and would greatly like to get this figured out.

    thanks for any help



  • I’ve got another as card that I have a copy of all my original files and folder etc. I put it into the board and it’s fine. But I don’t remember how to get to the web control interface. I also have all the remembered networks cleared using M588 S”*”. But still not gaining much ground on effectively joining networks. So if I could just get help on connecting to a network, then I believe I need the IP address assigned to my printer(or maybe I need to assign it).

    At this point I could care less about updating anything, it doesn’t seem like it’s worth the hassle. I just want to get back to what I had, and be able to print. But the guide that was around over a year ago is ofcourse gone. I’ve searched this forum, and google but can’t find it.


  • administrators

    1. The V2 firmware is for all Duet WiFi, Duet Ethernet and Duet Maestro boards. So you can use it on your Duet WiFi.

    2. In the command M587 S”wifi24” P”password” it looks like you are using the wrong type of double quotation marks. I guess this is a Mac thing. It should be M587 S"wifi24" P"password". Can you see the difference?

    3. From main firmware version 1.19 onwards, DuetWebControl no longer needs to be installed using M997 S2. You just need to have the contents of DuetWebControl.zip (not the zip file itself) files in the /www folder of the SD card.

    4. You need to have DuetWiFiServer 1.21 running on the WiFi module before the M587 command will work. So it you haven't already done so, copy it into /sys on the SD card, start the Duet and send M997 S1.

    HTH David



  • Since your firmware is earlier than v 1.19, there are more steps in the update of the firmware: Look specifically at https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware#Section_If_your_Duet_WiFi_is_running_firmware_1_18_or_earlier



  • @dc42 I’ll try again tomorrow. I’ll get the newer firmware for all three. Currently though I don’t have a /www file or folder, so I just create a /www folder and put the duetwebcontrol.zip file there? And was I correct when I downloaded it and made the entire folder downloaded to one zip file?

    I saw another post about the quote marks, and someone posted a “hey copy the way I have it here and it’ll work”, so I didn’t and just sub my info in. But I guess since I’m not running 1.21 Wi-Fi server like you said it doesn’t matter much.



  • Create the /www folder and then extract the duetwebcontrol.zip file into it.

    Once you get through this update future updates will be much much easier.



  • Thanks, tomorrow when I work on it I should get it. Thanks for all the help so far



  • @phaedrux hey when I download the zip file on my Mac, the actual file when done just shows as any other folder on my computer. I can turn it into a zip file, but without doing anything to it it shows as normal folder.

    And what do you mean by extract it? I appreciate all the help again



  • What exactly are you downloading?



  • The duetwedcontrol firmware



  • @advancedrescue So that file is a zip file. A zip file is a compressed container file that stores a bunch of other files. Extracting it means taking those compressed files out and turning them back into regular old files.

    DuetWedControl.zip contains all the files needed to make the DWC work. Those files need to be in a folder called WWW on the SD Card.

    When you download the zip file and open it on the mac, it will turn into a folder with the files in it. You can just rename that folder to WWW and copy it onto the SD card.

    After this it gets much easier, as you only have to upload the zip file to the web control and it will do the rest.



  • @phaedrux

    Ok, good news and some bad.

    I got the latest 2.02 firmware, the latest wifiserver 1.21, and duetwebcontrol 1.22.3 all running. I’m also finally able to get on the web interface.

    The bad:
    Not of my commands work. Home x/y/z/all... none are working. My tool heat up is working, and the fans kicked on like I have them set too.

    I want to say the other night I remember seeing somewhere in the many pages I came across that after a certain update certain config commands changed. But i visited so many pages I don’t remember, and there’s been so many updates I’ve missed that it could be any. I’ll get to looking but maybe someone can point me in the right direction. I’ll post G-Code console feed so you can see the errors

    Thanks so much for all the great help!
    0_1541970713521_console-2.txt



  • Yes there was a change that prevented movement of axis before they were homed.

    You'll have to either add a command to the config.g to allow those movements by default or you can edit your homing files to allow just those homing moves. Usually it's the z lift before homing x and y.

    From the FAQ

    I get this error message: "Error: G0/G1: insufficient axes homed" ¶
    Recent firmware versions do not allow axes to be moved before they have been homed. The only movements allows are homing moves (G1 moves with S1 or H1 parameter) and individual motor moves (G1 moves with S2 or H2 parameter). So any Z movements that your homing files make before Z is homed should use the S2 parameter. Alternatively, add M564 H0 to config.g to allow axis movement before homing.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.