New board can't update wifi firmware



  • I just received a new DuetWiFi board and set up the wifi and updated the firmware to 1.17c through a browser. That went smoothly.
    I then tried to update the WiFi server to 1.03 and I can't get it to install. I tried many times using different browsers and it gets to the point where the board
    disconnects and when it tries to reconnect there is an error that says Invalid Password. I have tried many times using Repetier Host by sending M997 S1 and getting the
    same results:
    06:36:52.718 : N73 M997 S182
    06:36:52.719 : serial: N73 M997 S1
    82
    06:36:54.672 : N74 M10520
    06:36:57.735 : N75 M105
    21
    06:37:00.798 : N76 M10522
    06:37:03.860 : N77 M105
    23
    06:37:04.689 : Trying to connect at 460800 baud: failed
    06:37:06.920 : N78 M10524
    06:37:15.647 : Trying to connect at 230400 baud: failed
    06:37:26.608 : Trying to connect at 115200 baud: failed
    06:37:37.568 : N79 M105
    25
    06:37:37.568 : Trying to connect at 74880 baud: failed
    06:37:37.568 : Error: Installation failed due to comm write error
    06:37:37.568 : ok

    There is a sticker on the Atmel chip that says it's 436/500, maybe that info will help somehow.
    Any help with this is greatly appreciated.
    Thanks,
    Allan



  • Have you tried the methods in the wiki?
    https://duet3d.com/wiki/What_to_do_if_your_Duet_or_Duet_WiFi_won%27t_respond
    Also I believe you need to connect main power when flashing the Wifi firmware


  • administrators

    Hi allanzo,

    I'm sorry to hear you are having problems updating the wifi firmware.

    If you are using USB power only, then please try updating using VIN power. If you can no longer connect via the web browser, please connect via USB and send M997 S1 instead.

    If it still fails with "Trying to connect at 74880 baud: failed", then please ask your supplier for a replacement Duet WiFi, and I would like the problem board sent to me for investigation.



  • I had the same problem, ended up having to hit erase button then reset. connected with usb and used the Bossa program to update. not sure but have had no problems with the board since.


  • administrators

    The WiFi firmware upload is completely different from the main firmware upload, and I would not advise erasing the main firmware if the WiFi firmware or DWC firmware upload fails.



  • Hi David,

    I tried updating using VIN power but I get the same comm write error. I tried updating through a web browser a few times
    and also via USB a few times.

    I'll contact Filastruder for a replacement and forward your request about the board.

    Thanks.



  • Hi,

    I'm getting excactly the same issue. Any news on this?

    Tried several times with both on the web browser and via OctoPrint on USB. The log is from OctoPrint. I also get asked for a password when I try to connect in web browser after a failure. I have to to a full power cycle to be able to log in again.

    Send: M997 S1
    Recv: Trying to connect at 460800 baud:  failed
    Recv: Trying to connect at 230400 baud:  failed
    Recv: Trying to connect at 115200 baud:  failed
    Recv: Trying to connect at 74880 baud:  failed
    Recv: Error: Installation failed due to comm write error
    
    

    I get a similar error with both M997 S1 and M997 S2.

    I updated the DuetWifiFirmware a couple of days ago accidentally hitting "Erase" on the board.

    Versions I'm at:
    Firmware Name: RepRapFirmware for Duet WiFi
    Firmware Version: 1.18beta3 (2017-03-16)
    WiFi Server Version: 1.02
    Web Interface Version: 1.12-RC1


  • administrators

    The strange thing is that all Duet WiFi boards are loaded with initial firmware in this manner. I guess there must be some difference between your environment and the test environment. Maybe temperature. With the files already on the SD card with exactly the right names, you could try commenting out the M552 S1 command in config.g so that the WiFi module is not started at power up. Turn off the Duet and allow it to cool down. Then turn it on and immediately send the M997 S1 or S2 command from USB or Panel Due. That will more closely replicate how they are programmed in the factory, with the WiFi module cold.



  • Finally got it flashing.

    I did what you said but no difference but then I went through all your messages again. I realised VIN-power. I'm using an external 5V and relay to simulate ATX power. I just needed to do a M80 before flashing.


Log in to reply