Pressure Advance not working on layer 1



  • I have two Duet-Wifi controlled printers, a Delta and an Ormerod 2. I've just recently become aware that pressure advance is not working on layer 1 on the Ormerod 2. Pressure advance on layer 2 and above is working as expected on the Ormerod 2 and works on all layers on the Delta. I'm using the same command on the config.g on both printers, M572 D0 S0.1. I have nothing in the slicer (S3D 4.1) that would explain this problem and do not know where to look to correct this issue. Here is my config running firmware 2.01:
    ; Ormerod 2 config file for Duet firmware
    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P ORMEROD2 ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S1 ; Enable FTP
    M586 P2 S1 ; Enable Telnet

    ; Drives
    M569 P0 S0 ; Reverse X motor
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M350 X16 Y16 Z16 E16:16 I0 ; Configure microstepping without interpolation
    M92 X87.752 Y87.752 Z396 E423:420 ; Set steps per mm
    M566 X1800 Y1800 Z40 E300 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z250 E3600 ; Set maximum speeds (mm/min)
    M201 X1200 Y1200 Z20 E100 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800:800 I30; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    ;M201 X800 Y800 Z100 E3600 ; Accelerations (mm/s^2)
    ;M203 X15000 Y15000 Z180 E3600 ; Maximum speeds (mm/min)

    ; Axis Limits
    M208 X-12 Y0 Z-50 S1 ; set axis minimum (adjust to make X=0 the edge of the bed)
    M208 X230 Y220 Z335 S0 ; Set axis maxima
    M564 H0 ; allow axis movement before they've been homed
    ;M556 S80 X-0.70 Y0.15 Z0.55 ; Axis compensation here
    ;M579 X1.003 Y1.003 Z1.001 ; Scale Cartesian axes directly

    ; Endstops
    M574 X0 Y1 Z0 S1 ; set endstop configuration (Y endstop only, at low end, active high)

    ; Z-Probe
    M574 X1 Z1 S2 ; Set endstops controlled by probe
    M558 P1 H5 F90 T6000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z1.755 ; Set Z probe trigger value, offset and trigger height
    M557 X25:190 Y20:200 S20 ; Define mesh grid probe from X=25 to 200, Y=10 to 210mm with a mesh spacing of 20mm

    ; Heaters
    ;M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T10000 B3988 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; Set temperature limit for heater 2 to 280C
    M307 H0 A187.0 C718.4 D3.3 B0 ; Heated bed auto-tune parameters
    M307 H1 A648.9 C82.6 D4.3 B0 ; point .5 Hot end auto-tune parameters
    M307 H2 A357.6 C44.0 D3.0 B0 ; Hot end #2 auto-tune parameters

    ; Fans
    ;M106 P0 S1 I0 F500 H1:2 T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    ;M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    ;M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 T45 H1 ; Set hotend fan1 for thermostatic control

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2 ; Define tool 1
    G10 P1 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C
    M572 D0 S0.1 ; Set extruder pressure advance
    M912 P0 S-7.2 ;Duet board temperature monitor adjustment
    M501 ;Read stored parameters
    T0 ; select first hot end



  • How can you tell it's pressure advance? What is actually showing as the problem?



  • Both of my printers use a geared extruder. You can see the gear stop at the end of a pass when pressure advance is working, or feel it stop when touching it. Or see that it is not stopping when PA is not working. What got me to look at it initially was the buildup of plastic at the end of the run that pressure advance normally prevents.



  • @ayudtee said in Pressure Advance not working on layer 1:

    M572

    If you send M572 when the print is going it will reply with the currently set value. Perhaps it is getting changed somewhere between the config.g and printing.



  • Good idea, I'll try it when I'm back at layer 1. Just started a 6 hour job..


  • administrators

    The first layer is typically printed more slowly than other layers. This in turn will mean that pressure advance will do less (or perhaps no) reverse motion of the extruder gears on the first layer.



  • @dc42 This makes sense as I've recently lowered the speed setting down to 30mm/s on the Ormerod. Thanks for your help.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.