Extruder runs into Part after Printing...



  • Hey Guys,
    I have recently changed the Board on my Leapfrog CREATR to a DUET 3D Ethernet, and the Extruder. For Slicing I use SIMPLYFY3D.
    Everything is Setup and works fine. Only Problem is, that after finishing the Print, the Printing Plate wants to rise, so that the Hot End runs into the Part. I was not able to find the routine, neither in the Slicing Software, nor in the Confoguration Files of DUET3D which are causing this. Any Ideas?
    THX



  • I can't answer with confidence for simplify3d but Slic3r has configurable gcode that it adds to the end of print that includes moving the head out of the way and disabling heaters. I'd be looking for something like that in your slicer.



  • Thanks. But I already checked that. Added: in Slicer:
    M104 S0 T0 ; turn off right extruder
    M140 S0 T1 ; turn off bed
    G1 S2 Z5 F100 ;
    G1 S1 X-205 F1200;
    G1 S1 Y-265 F1200;
    M84 ; disable motors

    So doesnt seems to be the Problem. Could it be some routine at the DUET Board?



  • As @DocTrucker has said. If you take look at the end of the gcode file you've printed, you'll find a command something like G1 Znnn. It's quite normal for slicers to be configured to raise the print head (or lower the print bed) at the end of a print and it sounds like yours is going the wrong way.
    Edit. Was typing the same time as you.



  • @glockster said in Extruder runs into Part after Printing...:
    .....................................

    So doesnt seems to be the Problem. Could it be some routine at the DUET Board?

    Unlikely. Can you post the last few lines of the gcode file you were printing.



  • I just checked. Nope seems to be correct:
    .
    .
    .
    ; layer end
    M104 S0 T0 ; turn off right extruder
    M140 S0 T1 ; turn off bed
    G1 S2 Z5 F100 ;
    G1 S1 X-205 F1200;
    G1 S1 Y-265 F1200;
    at the end of the File.
    And positive Z in Down not up on my movable Printbed. Works with all other Perimeters too. So no Idea what he is doing, from my side...

    Also he doesnt Home X and Y as commanded, he just raises Z instantly after the last Print step.



  • ; feature gap fill
    G1 X102.498 Y236.792 F4800
    G1 X102.607 Y236.683 E33774.7533 F640
    G1 X103.166 Y236.804 E33774.7807
    G1 X102.837 Y237.132 E33774.8029
    G1 E33773.8029 F1800
    ; layer 291, Z = 87.450
    ; feature outer perimeter
    G1 Z87.450 F1000
    G1 X103.205 Y237.811 F4800
    G1 E33774.8029 F1800
    G1 X102.032 Y236.636 E33774.8824 F384
    G1 X103.964 Y237.053 E33774.9771
    G1 X103.205 Y237.811 E33775.0285
    G1 E33774.0285 F1800
    ; layer 292, Z = 87.750
    G1 Z87.750 F1000
    G1 X103.321 Y237.694 F4800
    G1 E33775.0285 F1800
    G1 X102.926 Y237.298 E33775.0553 F384
    G1 X103.577 Y237.439 E33775.0872
    G1 X103.321 Y237.694 E33775.1045
    G1 E33774.1045 F1800
    ; layer end
    M104 S0 T0 ; turn off right extruder
    M140 S0 T1 ; turn off bed
    G1 S2 Z5 F100 ;
    G1 S1 X-205 F1200;
    G1 S1 Y-265 F1200;
    M84 ; disable motors

    These are the last lines.



  • @glockster Ok. The reason is that the gcode commands in the file are all absolute (as is normal) That is to say, the positions are all with respect to home which will normally be zero for all axes.

    So the command G1 S2 Z5 F100 will try to move the print head to the position 5 mm above the bed and as the prior position was 87.75 mm, it is going to get nasty. So what you need to do is add the command G91 prior to the G1 Z command. This will change the coordinate system from absolute to relative, meaning that the subsequent G1Z 5 command will move the print head by 5mm from where it happens to be, rather than to 5mm above the bed.

    HTH

    EDIT. If you want to move X to -205 and Y to -265 as well, you need to either do that before you add the G91 command then do G1 Z5. OR do this:

    G91 ;set relative
    G1 Z5 F100 ; lift head or lower bed by 5mm
    G90 ; back to absolute
    G1 X-205 Y-265 F1200 ; move head to X-205 and Y-265



  • Great, Thank You!
    Will try and leave a feedback.



  • It worked fine. Thank you guys for the help!



  • @glockster Glad that fixed it. Can you edit the title to mark this thread as "Solved".


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.