Calibrating the Z probe trigger height



  • I am currently trying to set the probe trigger height to start a test print. Using the guide:(https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe#Section_Calibrate_the_Z_probe_trigger_height)
    I am trying to jog the nozzle down to grip a piece of paper but the Mini differential sensor is preventing it. It's a stupid question but I am not sure what to change to get past this point. Using gcode is new to me coming from a preset Printrboard...
    The sensor is being used as my z probe, I am using a printinz plate, and I am getting the correct numbers for if a surface is near (465) and if the sensor is activated (535).

    Here's my config.g:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Aug 13 2018 00:33:59 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare

    ; Network
    M550 PIMJ - Printrbot SM ; Set machine name
    M551 Pimj349 ; Set password
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M569 P4 S0 ; Drive 4 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z2020 E96 ; Set steps per mm
    ;M92 E420:420 ; set extruder 0 and 1 steps/mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X9000 Y9000 Z360 E1000 ; Set maximum speeds (mm/min)
    M201 X2000 Y2000 Z30 E10000 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z900 E800 ; Set motor currents (mA)
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X250 Y150 Z150 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P1 H3 F120 T9000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z0.0 ; Set Z probe trigger value, offset and trigger height

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S1 I0 F500 H1 T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y26 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured




  • administrators

    Are you saying that it won't let you jog the nozzle down low enough? If so then it probably thinks you are at Z=0 already and you have the minimum allowed Z height set to zero. You can allow movement behind the limits by sending M564 S0. When you have finished, send M564 S1 to re-apply the limits.



  • @dc42 said in Calibrating the Z probe trigger height:

    M564 S0

    Yeah, the Mini Differential Sensor I assume is stopping it, I didn't know there was a behind the scenes limiting factor.
    Thank you I will try it once I get home and report back!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.