Zprobe offset. Solved



  • I am trying to recalibrate my zprobe. Its was working fine untill today when I changed the mount. Now when I follow the instructions I cannot move the axis until I home them, but when I do I cannot move the z axis below zero. If I use m564 H0 I can follow the instructions until the G30 S-1 command which then has error x+y axis not homed.
    If I put a rough estimate into the G31 Z command it does not appear to be taken into account and the head is always too high.

    Here are the instructions I followed :

    "Ensure that the Z offset in G31 in config.g is set to 0, these steps will be used to measure this actual offset. (send G31 Z0 to set it to 0).
    Use the X and Y jog buttons to position the nozzle over the centre of the bed
    Jog the nozzle down until it is just touching the bed or just gripping a sheet of paper.
    Send command G92 Z0 to tell the firmware that the head is at Z=0
    Jog the head up by 5 to 10mm
    If the Z probe needs to be deployed, deploy it
    Send command G30 S-1. The nozzle will descend or the bed rise until the probe triggers and the Z height at which the probe stopped will be reported. If you are using a nozzle-contact Z probe, the trigger height will be slightly negative. For any other type of Z probe where the probe triggers before the nozzle contacts the bed, it will be positive.
    Repeat from step 5 two or three times to make sure that the trigger height is consistent.
    In Duet Web Control, go to Settings -> System Editor and edit the config.g file. Set the Z parameter in the G31 command to the trigger height that was reported. Save the file."

    Thanks.


  • administrators

    @micktol said in Catch 22, Zprobe offset:

    I am trying to recalibrate my zprobe. Its was working fine untill today when I changed the mount. Now when I follow the instructions I cannot move the axis until I home them, but when I do I cannot move the z axis below zero. If I use m564 H0 I can follow the instructions until the G30 S-1 command which then has error x+y axis not homed.

    The G30 command requires X and Y to have been homed, regardless of the M564 setting. If for some reason you can't home X and/or Y yet, you can cheat by using a G92 command to tell the firmware the X and Y coordinates, for example G92 X0 Y0. That will flag the X and Y axes as having been homed.



  • Thank you for your reply David, I am able to get a value from the G30 S-1 command but it does not seem to be applied!
    I have a corexy with sensorless homing on x+y and a pnp sensor on z. This is my config.g file:

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S0 ; Drive 4 goes forwards
    M584 X0 Y1 Z2:4 E3 ;dual Z
    M671 X-44:252 Y105:105 ; bed motor positions

    M350 X16 Y16 Z16 I1
    M350 E64 ; Configure microstepping with interpolation
    M92 X81 Y81 Z400:400 E562 ; Set steps per mm
    M566 X1800 Y1800 Z12 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E3600 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z250 E1000 ; Set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E1200 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    ;Extruder
    M207 S5.0 F2000 ;Retraction

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X195 Y210 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 X0 Y0 S0 ; Set active high endstops
    M915 X Y S3 R0
    ; Z-Probe
    M574 Z0 S2 ; Set endstops controlled by probe

    M558 P8 I1 X0 Y0 Z1 ; Set Z probe type to switch and the dive height + speeds
    G31 P600 X0 Y45 Z0.665 ; Set Z probe trigger value, offset and trigger height
    M557 X10:185 Y45:175 S20 ; Define mesh grid


  • administrators

    • What type of Z probe are you using? P600 in the G31 command is an unusual value these days.
    • Is 0.665mm the Z probe trigger height that you measured?


  • David,
    I have an inductive pnp sensor, I have tried setting it to type 5 and 8. The values it shows in dwc are 0 and 1000.
    The 0.655 is the result of the G30 S-1 command.
    What is strange is that it was working fine until I tried to recalibrate the height of the z probe.



  • @micktol Are you by any chance using config_override.g and is there an M501 in your config.g. This would explain why changes to config.g seem not to be applied. Just a thought.........



  • Deckingman, I do not have any M501 commands but you made me think so I looked in my homeall.g and there is a M92 Z command which was overriding the G31 command. the M92 Z value was fine before I moved the probe!

    Thanks Deckingman and David for your assistance.



  • @micktol Glad you got it fixed. Can you edit the title of your first post and add "SOLVED" to the end of it.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.