[SOLVED] Thermistor Pull-Up Resistor is Off (Maestro)



  • I've been chasing down some issues with my thermistor reporting temperatures that I suspect were really off at high temperatures, switched to a PT1000 and the problem became apparent at 20C. Switched that to the second thermistor channel and it all worked fine.

    In the end the pull-up resister on the first thermistor channel reads 1.72k on my multimeter, and when using this value room temperature is spot on for thermistors and PT1000.

    Is there any reason why I wouldn't be able to use it using a configuration like:

    M305 P1 X501 R1720

    Thanks.


  • administrators

    That will work if the thermistor reference resistor really is 1.72K. But it seems odd that your Maestro would have a resistor of that value. Can you compare the markings on all 4 thermistor reference resistors? The schematic (giving the component IDs) is at https://github.com/T3P3/Duet/blob/master/Duet2/Duet2Maestro_v1.0/Duet2Maestro_Schematic_v1.0.pdf.



  • @dc42 Already done. I checked all the resistors, they are green(-ish) and look to be marked 220. R15, R19 and R53. Values are very close to 2.2 for all the other resistors except this one (R15) which measures 1.7.


  • administrators

    @iratecrayons, I've never heard of a resistor having a value different from the one that is marked. IMO that qualifies for a warranty replacement.

    If you want to keep that board, setting the correct value in M305 will work around the fault. However, I suggest you take a careful look at the corresponding pin on the microcontroller, in case the real fault is that the pin is shorted to an adjacent one.



  • Went over the leads and followed the traces as best as I could, everything checks out. I have two PT1000 so I put them on E0 and E1 channels and set them on the warm heat bed, they seem to track closely at the low temperature.

    Since there doesn't seem to be any obvious problems with using it with a lower resistor value I think I'll just keep the board as it is.

    Thanks again for your time and response.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.