Z Probe trouble (Solved)



  • Good Day,
    I have built a DIY Cartesian printer with the bed moving up and down for Z height changes. I have installed a end stop micro switch at the bottom ( Z height at max) and I also have a pinda probe at the nozzle just like the original Prusa. The pinda probe is a Original Prusa MK2s 3 wire probe. I have tried to use the pinda probe for Z height and am able to move the bed up and down using the Jog feature. When I try and home the bed crashes into the Pinda probe.

    The Z probe reading on the web GUI reads about a 1000, this is with the ground hooked up to ground and the sensor wire hooked to the Z_Probe_Mod and the 5V power coming from VFan Jumper.

    I have also tried hooking the sensor wire to the Z-Probe_in and get a reading of about 885 on the web GUI.

    I'm not sure if I have a setting in the firmware wrong or a wiring connection issue.

    Without any success with the Pinda probe I tried using the end stop switch but when I try and home the Z axis the bed will only move about 20mm or so and I can not use the Jog feature to move it at all.

    I have tried pushing the micro switch by hand to trick it into thinking the bed is in the full max z height but that accomplishes nothing.

    Another little issue I have is after homing the Y axis (end stop switch is at Y Max) the carriage does not move to the Y min position after it activates the end stop switch. I am able to toggle it there or it will move there when I try am home the Z axis. How do I get it to move to Y min after homing "Y"?

    Anyone who can guide me in the proper direction will be much appreciated. Please keep in mind I am a newbie at this and not terribly computer savy.

    Cheers,

    Leif



  • Can you post your config.g and your homing files? That's where all the action will be.

    I'm not sure if you have the probe wired correctly.



  • Here they are As requested:

    Config G

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun Nov 18 2018 18:17:16 GMT-0800 (Pacific Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"BIG HELGA" ; Set machine name
    M552 S1 ; Enable network
    M587 S"TELUS1901-2.4G" P"g54y3tkwdb" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E127.32 ; Set steps per mm
    M566 X600.00 Y600.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z240.00 E1500.00 ; Set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z100.00 E10000.00 ; Set accelerations (mm/s^2)
    M906 X950.00 Y950.00 Z1050.00 E950.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X650 Y350 Z344 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y2 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z2 S2 ; Set endstops controlled by probe
    M558 P2 H5 F360 T6000 ; Set Z probe type to modulated and the dive height + speeds
    G31 P500 X12 Y23 Z1 ; Set Z probe trigger value, offset and trigger height
    M557 X15:635 Y15:335 S20 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 X200 ; Configure thermocouple for heater 1
    M143 H1 S300 ; Set temperature limit for heater 1 to 300C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"#1 Primary" D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    HomeZ G:

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun Nov 18 2018 18:17:17 GMT-0800 (Pacific Standard Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X3 Y-8 F6000 ; go to first probe point
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    Homeall G

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun Nov 18 2018 18:17:16 GMT-0800 (Pacific Standard Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-655 Y355 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y-5 F6000 ; go back a few mm
    G1 S1 X-655 Y355 F900 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X3 Y-8 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning


  • administrators

    The output of the Pinda should be connected to Z_Probe_In. The reading should be zero when the probe is not triggered, and a high value (normally 1000) when it is triggered. If you find that it is reversed, add or remove parameter i1 to the M558 command. See https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe.



  • Just so I'm starting out right I have configured in the REPRAP configuration for "Simple modulated IR Probe".
    The M558 command did not have I1 in it so I added it at it looks like this "M558 P2 H5 I0 F360 T6000" When I put the "I1" the Z-Probe reading shows "1000 (948)" so I switched it to "I0" as shown above in the M558 Code, then it reads "0 (948).
    The Z-probe is connected to the "Z_Probe-Mod" and the light on the Pinda probe is lit up. When I put a metal object to it the light goes out but the value displayed does not change.

    With the wiring hooked to the "Z_Probe_In" the light does not illuminate on the Pinda Probe. The Z Probe reading shows "0 (885)" with the "M558 P2 H5 I0 F360 T6000". When the "I0 is changed to "I1" the z-probe reads "1000 (885)"

    In all the configurations I have tried I cannot get the values of the Z-Probe to change when trying to trigger the probe with a metal object.


  • administrators

    @pc-6 said in Z Probe trouble:

    The Z-probe is connected to the "Z_Probe-Mod" and the light on the Pinda probe is lit up. When I put a metal object to it the light goes out but the value displayed does not change.

    As dc42 says it should be connected to Z probe In.

    Also its not a modulated IR probe but an inductive probe:

    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_NPN_output_normally_open_inductive_or_capacitive_sensor



  • I have now connected to the "Z_Probe_in" (Light on the probe is off) and changed the M558 P5 H5 I1 F360 T6000 and still cannot get Probe to trigger. Z Probe reading always at 0



  • @pc-6 Do you have a v1.04 board then? If not, then that link that @T3P3Tony posted up indicates that for a capacitive sensor like that, you need a diode.

    I'm more watching this, as I am looking at different possibilities for a Z probe on my MakerBot clone printer. I have a piezo Z probe on my leadscrew printer, which works pretty much as expected, but I have a capacitive sensor that I'm thinking of using. In my case, I have a v1.03 board, so I'd definitely need the diode.

    Pictures of your connection and probe may help people diagnose it.

    You say that the probe does not light up. There should be a minimum of 3 wires going to the probe. It ought to have +Vcc, Ground, and a signal wire. +Vcc should be connected to an approprieate voltage source, as dictated by your probe's documentation. It seems that the Pinda probe should operate on 5V, so it is not appropriate to run this from the +Vcc on the Z probe connector, as this is 3.3V. You should be able to grab +5V from the PanelDue connector next to the Z probe input. You can use the ground and IN pins from the Z Probe connector though.



  • I do have the 1.04 board. The light will illuminate if I plug the signal into the Z_PROBE_MOD but this is not the correct location, when it is in the Z_PROBE_IN is when it does not light up. I am pulling 5V power from the V Fan Jumper because I have a PanelDuo attached.
    A picture of it is not very realistic as it is installed in a case with a huge mass of wires making it exceedingly difficult to photograph ( I tried and I can discern much from the photo) and the Probe is from a Prusa MK2s, (Not much to look at)


  • administrators

    Are you certain that you don't have the connections to the Ground and Out wires swapped? What colours are those wires?


  • administrators



  • Well thank you all for your help. With dc42 suggestion and Link to wiring diagram from T3P3Tony I have it fixed. I had the black and blue crossed. (So much for making black the standard ground or negative).
    All is working as it should.

    Cheers everyone.
    Leif



  • This post is deleted!

 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.