[Solved] Duet 2 wifi Java error



  • I have installed a new Duet 2 wifi of a Chinese Prusa i3 clone. Everything was working fine except for G29 homing which I was working on, after editing config.g to redefine the grid pattern, the Duet dropped the wifi link and on restart the extruder heater had vanished from the screen on both the pc and Paneldue and the bed heater displayed an incorrect temperature (2000 degrees).
    I have checked all thermistors and heaters for continuity and all check out ok
    I have reinstalled the the latest RepRap and WebControl Firmware to no effect.
    I have tried resetting the board
    The test heater macro brings up three heaters, all current temperature are n/a the tool fan also starts up at 35% and an Error Screen displaying the following:

    A JavaScript error has occurred so the web interface has closed the connection to your board. It is recommended to reload the web interface now. If this happens again, please contact the author and share this error message:

    Version: 1.22.4-b1
    Message: TypeError: getTool(...) is undefined
    URL: http://192.168.1.5/js/dwc.js
    Line: 9406:16
    Error object {}

    I'm at a loss as to how to proceed, other than erase the memory and start again which I'm happy to do but need to know the exact procedure ( Is teh Erase jumper bridged with the board powered up?)

    All help will be greatly appreciated, thanks in advance



  • @crazyjane Some further information:
    The Duet 2 control panel LED status is as follows:
    LED E1 Heat - Off
    LED E0 HEAT - Off
    LED VIN - On
    LED +5V - On
    LED +3.3V - On/



  • Wow!!! After countless edits and reloads of config.g everything suddenly miraculously returned to normal.
    I'm delighted to be back in action but concerned that there is some intermittent glitch in my setup, so I'd still welcome other opinions, comments and advice!


  • administrators

    Did you upgrade the main firmware, or Duet Web Control? The version of Duet web Control you were running was a beta.




  • administrators

    Thanks. My guess is that you either hit a bug in the DWC beta that you were using before, or you were running incompatible versions of main firmware and DWC. I'm glad it's working for you now using the very latest releases.



  • Thanks for your reply, just to confirm, I had already upgraded the Firmware when the problem file, but I accept that it could have been caused by something that I did when I tried to save the config.g file. The error corrected itself after renaming the config.g.bak config.g


  • administrators

    @crazyjane, do you still have the original config.g file that provoked the error?



  • @dc42, below is the config.g file I was using. I had changed the mesh pattern when the problem occurred:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Wed Nov 14 2018 18:01:46 GMT+0000 (Greenwich Mean Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"XXXXXX setup" ; Set machine name
    M552 S1 ; Enable network
    M587 S"vodafone-B51C" P"XXXXXXXX" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z462.43 E98.61 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X200 Y270 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active high endstops
    M558 P5 X10 Y-50 Z1 H5 F120 T6000 ; Set Z probe type to switch, the axes for which it is used and the probe + travel speeds
    G31 P50 X10 Y-50 Z-.13 ; Set Z probe trigger value, offset and trigger height
    ;M557 X30:260 Y30:250 S20 ; Define mesh grid

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P5 H5 F1200 T6000 I1 ; Set Z probe type to modulated and the dive height + speeds
    G31 P500 X10 Y-50 Z-.13 ; Set Z probe trigger value, offset and trigger height
    M557 X15:12 Y15:195 S20 ; Define mesh grid
    G29 S1

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured


  • administrators

    @crazyjane said in [Solved] Duet 2 wifi Java error:

    M557 X15:12 Y15:195 S20 ; Define mesh grid

    Thanks. Looks like you accidentally set the upper X limit below the lower X limit. I'm guessing that the firmware doesn't do appropriate error handling in this situation. I will test it.



  • @dc42 oops, I didn't see that, obviously a typo while I was changing the Z trigger. That might be the cause of the problem, I would also point out that the problem was resolved after reflashing the PanelDue i7, could it have caused the issue?
    Anyway, you will be glad to hear that everything is fine and the first job is running for the past 3 hours or so, and I cannot say how delighted I am at the quality of the print, streets ahead of the original MKS 8 bit board.
    Thanks for all your help and interest, much appreciated


  • administrators

    I don't think that M557 line was the cause of the problem, because the error handling does seem to work properly:

    m557 x15:12 y15:150 s20
    Error: M557: bad grid definition: X range too small
    
    m557
    Grid is not defined
    
    g29
    Error: G29: No valid grid defined for bed probing
    

    It could be that after upgrading Duet Web Control, your browser still had old versions of some of the web files cached, and the mismatched files caused the problem. It's wise to clear the browser cache when upgrading DWC.



  • I'll do that in future!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.